How to stop quantizing controller data?

Hello fellow Steinberg customers,

I drew a long descending straight line in the cc11 Expression controller lane, with Snap turned off. However, the little dots are not making a straight line, they are stepping down basically increments that I assume correspond to the quantize value (I tried using the high 1/128 value) – resulting in a jagged line. See screenshot attached. This stepping is audible in the string part that is playing.

Can anyone explain what setting I’m missing, or why the controller data is being quantized?

Thanks!
cc11.jpg

pg 137 cubase 7.5, under quantize panel you have midi cc uncheck it . If you activate this button, controllers related to MIDI notes (pitchbend, etc.) are automatically moved with the notes when these are quantized. hope it helps.

Thanks for the help, rita. I located that information in the CPro8 manual on page 238. Although it seemed to be relevant I don’t think that is exactly what I’m looking for. I’m not looking to make controller data move with notes that are quantized, I’m just looking to make a smooth line so a long note isn’t audibly stepping down in volume as the expression controller goes down. Also the midi part I am working on has never been quantized. Thanks anyway though, I learned something from your reply.

Any other users have any info about making a smooth controller line? I vaguely recall perhaps being able to turn off snap and that would result in smooth lines. But that doesn’t seem to be working here.

Thanks for any help.

Just to be certain it is a quantization problem, what does it look like if you have Snap Off, but a low Quantize setting such as 1/4 (so you can really see if it then corresponds with quarter-note steps… it was a bit difficult to see, from your screenshot, if that was indeed 1/128 stepping)

with snap off and low quantise option you should get smooth curves. i cant think of other reason, also try doing it on a new project and let us know.

I tried it with snap off and low quantize value - same thing, lots of little steps instead of a smooth line. I will try in an empty project shortly and let you know.

Fyi, I tried this in an empty project and same thing, lots of little steps instead of a smooth line. Is there a preference somewhere that can increase the number of points Cubase uses to draw a line or a curve? (I vaguely recall back in earlier versions you could limit the number of points so that lines and curves would not create too much data.)

Thanks for any help.

If fact, as regards MIDI CC# data there is really no such thing as a straight line… if you start a MIDI CC# automation curve at zero, and make a slope all the way up to 127, you are in fact transmitting 128 discrete MIDI data events. Any software that is showing you a “smooth diagonal” isn’t really telling you the truth :wink:. This is not a Cubase issue, it is just the way MIDI works.
Yes, there is still the option to reduce the number of individual points (but only after recording… MIDI menu>Functions>“Thin Out Data”), but absolutely no way of increasing them beyond 128 (including the zero)
When you say you can hear the volume “stepping down”, then you either have excellent hearing, or the receiving instrument isn’t handling the CC data very well (sometimes referred to as “zipper noise”, but that isn’t just “steps”, it is an actual “spitting sound” between the steps).

What is this “midi” you speak of?

(that was a joke, right? :wink: )

Yes, sorry, was just about to edit as I forgot to to add “(just kidding)”. Thanks for your help!

Phew!.. I am relieved :stuck_out_tongue: :wink:

But seriously…I think it’s understood that a lot of us here have played around with midi ever since it was invented. Can anyone specifically confirm that the recording of controller data in Cubase is limited to the 0-127 increments of the old midi standard? And can anyone specifically confirm that this is the reason for jagged cc11 expression controller lines? (Or is there some other reason that perhaps points to a solution?)

If the recording of controller data is limted to 0-127, why does the numerical value for pitch bend, for example, show over 8000 increments in either direction (up/down)?

Surely there is a way to draw a straight smooth line for a cc in a present-day DAW. I think I remember the old Pro24 days when the sequencer would warn you about too much controller data if you did not limit the steps/increments essentially by quantizing. This seems to indicate that there should be a greater density of controller increments available.

Thanks for any help!

Because, unlike CC# data, pitchbend is actually spread across two data bytes.
Anyways, even if CC# data could be recorded with a finer resolution, the receiving instrument wouldn’t know what to do with that extra data… if volume, expression, or whatever CC parameter, is controlled by MIDI, it is expecting to see one of 128 values for it.
The possible exception is Registered and Non-Registered Parameter Numbers (at the discretion of individual manufacturers), whereby a parameter is (similar to pitchbend) stored over two data bytes, but, unlike pitchbend, it is simply recorded as two separate controllers (each with the now-famous 128 point stepping :slight_smile: )
Anyways, no need to simply take my word for it :wink:
http://www.midi.org/techspecs/midimessages.php

I’m afraid that is a very optimistic reading of it :wink:
Back in the Pro24 days, you could flood an Atari simply by sending too much data too quickly (but the data itself has always been that of the Standard MIDI Protocol). The purpose of the quantizing, in that instance, being precisely to avoid sending data bytes too close to one another)

I’ve done some editing of Midi CC 1 Modulation in the Project window (not in the Key Editor). In the Project Editor instead of drawing Midi CC events with pencil or line, its done with adding nodes. Between each node is an exact straight line.

Yes, that’s what you are seeing, but it is still generating individual bits of data (in steps).

Thanks for the info everyone. Maybe I’ll draw my cc lines on the project page and hope for a smoother sound.