How to stop warnings about missing port?


I have an arrangement with a bunch of midi tracks routed to VST instruments that are “Disabled”. Every time I load this arrangement I’m warned that midi tracks are missing the ports - because the VST instrument are disabled. When I click OK I’m asked if I want to delete those midi tracks, but I will not, so my question is how can I avoid those warnings?

Any Help Much Appreciated! :smiley:

Do I presume that, at some point, you will be wanting to re-enable those instruments?
Otherwise, just change the tracks’ routing to “Not Connected”, and re-Save.

Yes I might want to re-enable those instruments. It will be as a part of a template. Quite annoying that I can’t turn that warning of, or Cubase can distinguish between a disabled instrument and no instrument.

In fact, I had not yet tried this myself, so I have just done so… and everything is fine here (Mac).
I presume by “disabled”, you mean you have switched the instrument “Off” by the blue button at the top-left of the plugin window?
Btw, I tried also using an Instrument Track (doing the same thing), and also by disabling the Instrument Track itself (not the Instrument that it is triggering).
Was fine here in all cases.
Do I need some more info?

No way of avoiding this that I know of but to automatically close (ignore) this appearing window at launch I use a script I made in ‘autohotkey’

But as you are on Mac I do not know of an alternative method you might use.

I think if you “disable” the midi tracks connected to that instrument you won’t get the warning. No guarantee they will reconnect correctly when you re-enable it all. It seems quite buggy in regards to that feature.