How to stretch final bar

The last bar of my piece is on a line of its own. Is there anyway I can extend it out to allow more spacing for the notes? I’ve tried Engrave Mode then the |<—>| on the left panel, but the blue boxes don’t move when I click and drag them. What am I doing wrong?

Hi @sunny16 the note spacing in engrave mode doesn’t react to dragging. Instead, after selecting the big blue square at the end o the last system, try using alt+ right or left arrow. If you use alt+command(control)+ right or left arrow you will move in bigger steps. Here some more detailed shortcuts:


There is also a layout option that let you decide if the last system will be justified depending on how full it is: