how to turn off auto highlight?

Really getting tired of accidentally editing stuff cubase is highlighting for me.

Can you please be a bit more specific about the highlight you are referring to? Are you referring an event being selected after it is recorded (or the selection of the 2nd event after a split, etc)? Are you using the Object Selection (pointer) or Range Selection Tool for editing?

What options do you have checked for Preferences, Editing?

Nothing having to do with recording. Say I delete a part or an event or an automation point, the subsequent event always highlights itself.

Link editors and automation follows events are the only options checked.

I’m sorry but I am not aware of a way to have Cubase not select the next event on the track.

Try a macro:

Edit - Delete
Edit - Select None