How to turn off this "Snap Point Marker" in Audio

How do I turn off these “snap point makers” (i think they are called) in Cubase? Couldn’t find anything in the manual.

I wanted to add an image for you to see but unable to here. I recorded an audio and getting these vertical lines in random places in the audio. I wish all these extra features would be off as a default.

You probably want the preference “Enable Automatic Hitpoint Detection” off. (Since you mention many vertical lines)

The snap point is a different thing, it’s this vertical line that has a little “S” button attached that determines the position where your audio event will snap to grid.

Keep in mind that changing the preference will not remove the hitpoints from where they already exist, it will just turn them off for any new audio you record/import. To remove them from an existing event you must use the command Remove Hitpoints, in Audio>Hitpoints.