How to use "Common Position"?

What’s exactly this feature in PREFS/EDITING/TOOL MODIFIERS/SIZE OBJECTS : “Common Position”?
How do I use it?
The manual doesn’t state any help on this.

Niek/ Amsterdam

It’s for resizing objects. If you hold down the modifier keys, selected objects with different start or end locations get the same start or end points depending on the context. Try it out.

Thanks Steve , your explanation did the trick.
First I was experimenting with events “behind each other” on the same track, with unexpected results, but with your explanation I found out that this feature only affects events “below each other” .

Thanks!

Niek/ Amsterdam

What do you mean by “below each other”?

I meant: first I was struggling/experimenting with events which were placed on the same track, but that gave not the desired result. Then I found out that this “Common Position” only works when selecting events which are placed on different tracks, with other words: below each other.

But it does work on objects on the same track.

Hmmm, then I think I don’t completely understand the workflow yet:

When I select 2 events, both of a different length, and both on different tracks, and when I resize the start of the upper event with the “common position”-modifiers pressed , the start position of the the lower event is immediately taken to the start position from the upper event. The same counts for the end point , and the same is true for the upper event when I resize the start- or end point of the lower event.

But when both events are on the same track with, lets say: 5 seconds between them, and when I select them both, and start resizing the start point of the first event, nothing happens.
When I select both events, and start resizing the start point of the last event, nothing happens either.
When I select both events, and start resizing the end point of the first event though, then the end point of the first event is extended to the start point of the second event, and the second event is truncated to a length of 0:00 seconds, of which I can’t see what’s the point?

Am I doing something wrong?

Niek/ Amsterdam.

It does work. Try pressing the modifiers after pressing the mouse.

I did that.
First I pressed the mouse, then I pressed the modifiers (alt+control…I work on a Mac).
I’ll check it out tomorrow, I’ll get back to you.

… now THAT would be interesting! I thought the modifiers only took effect when you engaged them B4 you click. :astonished:

No they work this way too, and that also means that you can use more different combinations of them…

Hmmmmm! :slight_smile:

I made this screen recording which shows how “Common Position” functions (on my system) on 2 selected events which are first placed on 2 different tracks, and then placed on the same track.

You’ll see that nothing happens when the 2 selected events are not “within each others reach”, but when I move the 2 events closer to each other (they vertically overlap) “Common Position” starts to work. To make things clear I toggled my ‘control’-modifier a couple of times during “Common Position”-resizing (control+option) so one can see what’s the difference between “Common Position” (control+option) and normal-resizing.

Again; in my view “Common Position” only works as expected when the selected events are on 2 different tracks and doesn’t work as expected when the 2 selected events are on the same track.

I wish Steinberg explained its functionality in the manual while I think there’s quite a catch in how to handle and what to expect when using “Common Position”.

https://www.dropbox.com/s/8whb5hp0kqn5czu/NUENDO%20COMMON%20POSITION.mp4?dl=0

Maybe the tool is different on Cubase compared to Nuendo? (though that does seem unlikely) Or, is it possible that the maximum length of the audio events is impeding the function? (Is it the same if you first shorten the parts? )

Or, just to see if it works, experiment with midi parts to eliminate the aspect of audio file length limiting the ultimate length of the parts, since an audio event can only be as long as the file it contains.

I think audio file length is the problem, because it’s working here.