How Wavelab affects system clocking & related strategies

i’ll try to keep things clear here… but, a question about sample rate locking throughout the system as it relates to WaveLab.

a little rundown of my mastering chain/workflow:

  • i play from pro tools, through the analog chain, and capture in wavelab. until last week, the Lynx Aurora(n) was my system clock that clocked and fed a Cranesong HEDD 192. i would set the proper sample rate in the pro tools session and it would set the Lynx rate which would, via a word clock cable, change the HEDD. i would then have to manually set the recording rate (in the record dialog box) in Wavelab to get everything to gel. (i still miss that “bug” that PG had a few versions ago that allowed wavelab to see a different sample rate and then auto switch). if the Wavelab recording sample rate wasn’t set to the same rate as the pro tools session, pro tools would get upset and not play until i properly set the WL rate.

it was all fine, it was my way of working and worked great.

fast forward to this past week when i obtained a HEDD Quantum to replace the 192. because of Cranesong touting the quantum’s clock so much i decided to have the HEDD clock my system instead of the Lynx… and here’s where the quirkiness arises.

today i’m working on an ITB job… wavelab is not recording anything or even open… yet, when i made my new session in pro tools to the client’s sample rate (96k in this case) pro tools would not play unless i opened wave lab, went to the record dialog box, set the recording rate to 96, closed it up and then quit wavelab (since i don’t need it for this session)… then pro tools would play normally.

and that’s fine, just a step i have to make sure i do even when working without WL on an ITB job in pro tools… but my question is just a curiosity i guess… wondering why wavelab continues to dictate, or at least want to join the party, of the system sample rate even if it’s not open or being used. what is it about setting the recording sample rate in wavelab that influences the HEDD, pro tools, the system clock, even when it’s not open.

not a “problem” as much just wondering what’s at play here… if anyone can even answer that… perhaps it’s just too idiosyncratic… each of our systems and workflows…

anyway… onward.

-taylor

Hi!

Can you break it down…
Lynx out to with sample rate
in to etc software and hardware, step by step
I’m sorry but make you setting more easy to follow
at least for me
thanks

regards S-EH

hi, yes, sorry! i know i maybe didn’t explain myself clearly enough.

HEDD is master clock via sample rate selection on front panel. Lynx being clocked from HEDD via word clock cable. Pro Tools session set to proper (HEDD) sample rate.

Mac Pro Tools audio via thunderbolt to Lynx Aurora(n).

AES out of Lynx into HEDD Quantum

analog out HEDD to analog mastering chain

analog in HEDD from analog mastering chain

AES out of HEDD back into Lynx

capture in Wavelab

** that’s the full analog mastering chain

my question arises when i’m NOT capturing into wavelab and only rendering in pro tools without wavelab needed, or open… why WL’s RECORD dialog box sample rate (when it’s not even open) prevents the system from running if it’s not manually set to the current system (HEDD) rate.

for example, say… last session i was capturing in wavelab at 44.1k, this session, no analog capture, but pro tools session at 96k. wavelab, tho not open, was last set to capture at 44, thus was last set at a different rate than pro tools and even, while closed, not allowing pro tools to play or my system to all get the correct clock from the HEDD.

again, why does WaveLab, EVEN WHEN NOT OPEN, influence my system sample rate, despite the HEDD being the master clock.

hope that is clearer?

and… well, for what it’s worth… just switched over to a job where i AM going analog and recording into wavelab and pro tools/HEDD was at 44.1 and WL still set to 48k input… and i didn’t have any playback issues while the rates were mismatched.

the above issue arrived when PT/HEDD was at 96k and WL record input was 44 or 48 (i forgot)…

so… who knows… maybe it won’t be an ongoing issue.

FWIW, I’ve never seen WaveLab influence another program when it’s not open. I use a few apps (WaveLab, REAPER, RX, and sometimes Pro Tools) and the HEDD Quantum is my master clock for my RME AES card and I’ve never run into such an issue.

Maybe PG can weigh in but I think unless WaveLab is open and actively using an audio device, it should have no influence on it.

sounds fairly similar, at least re: HEDD/clock, justin. yeah, who knows. just strange that it’s happening. PG may know … ? if not, i’ll just keep an eye on when it happens again.

I would honestly look more at the Lynx here. Maybe it’s not correctly providing Pro Tools with the current sample rate and communicating that with the HEDD Q like WaveLab can.

I remember when I had my Lynx AES16e card before the RME, the Lynx required a bit more babysitting than expected.

the problem isn’t pro tools locking on, it always does, it’s wavelab refusing to let go of an old rate and locking up the system (as i said, even when it wasn’t open).

the lynx control panel doesn’t have too much that i think would affect things… i’ve got it slaved and locked to the HEDD… not sure what else i can do there…

Maybe PG can weigh in but I have not experienced WaveLab not letting go of device when it’s quit.

Thanks for breaking it down step by step
and seriously I have no clue right now why

This sound strange if this happens it means that the driver for some reasons
is not letting go when closing WaveLab is that possible !?

hopefully PG have ideas here or someone else
thanks

regards S-EH

WaveLab has no such control on the audio device driver. Actually, WaveLab has no control at all. For example, if WaveLab requests the driver to change the sample rate, the driver accepts or not.
And when WaveLab quits, of course WaveLab is not “alive” anymore to access the driver.

Maybe the issue exists because you have WL assigned as an external process from within PT?

well, more strangeness today… i had my system set at 48k (HEDD & Lynx locked)… wavelab was not open, but last set to record at 44.1k.

i opened iTunes to play some music and it was all transposed up… like what happens when you play at the wrong sample rate.

i opened WL, went into the record dialog box and changed the record sample rate (even tho i didn’t need WL nor was recording into it) to 48k, quite wavelab, and iTunes played as normal.

something strange going on for sure!

as @Justin_P suggested i looked into Lynx settings and there really isn’t many settings and none that would seem to affect this …