HSO and micro tuner midi plugin issue

I made some midi tracks with halion symphonic strings on them to make oriental music with oriental scales using micro tuner,when i press a key on the controller keyboard the sound is pitched correctly by micro tuner,but when i release the key it makes sound(i guess it’s a release note programed for HSO string sounds) but with the “original” pitch.
so keydown is pitched by micro tuner and key off is not pitched by micro tuner :unamused:
this does not happen with other VSTi… for example strings from halion 5…
any solution for this ?


There are two ways, how to write the MIDI Note Off message. One is really to write Note Off, but this is not used very often. And I guess, HSO doesn’t use it. Even most of MIDI Controllers just don’t send this. The 2nd way is to send MIDI Note On with Velocity = 0, which is much more common way.

Could you somehow verify, which MIDI message is sent?

Could you upload an example (MP3), please?

when press the keys it shows note on(velocity value),when releasing keys it shows note 0…

when playback the midi track it shows only the note on(velocity value) and a comment of MT(micro tuner i guess) on the tunes note…

in some HSO sounds,the issue not happening even in some octaves of the same voice program.it’s probably does this when a voice is programed and layered with special sound on release key (or note end on recorded midi). the micro tuner not pitching on note off(or note on 0)

here is an audio example:
the first 2 notes are not pitched, the third (and fourth)is pitched down 50 cents
and when note ends it sounds the original pitch

HSO doesn’t apply the pitch shift to the “Ambiance” for some reason. Bug? Maybe.

But here’s a workaround: turn off the Ambiance parameter by increasing the control to maximum. Yes, I see the irony. :wink:

Or if you’re using it inside Halion you can use the Tuning Scale midi module to create your scales. You can have multiple modes by using multiple Tuning Scale modules, and turn each on and off using CCs after you do a Learn CC for each module’s “Amount” control.