Hub still not working

Still cant get the hub to work here. I know I can disable it, but I would like to have it working. The annoying bit is that as soon as you try it you cant do anything else (like ferret around in firewalls) to see if you can fix it. All work stops when trying the Hub.

Steinberg please fix or post some kind of solution for those of us with this issue. My wish is for it not to hog all screens too.


My hub was working for a month or so, then it stopped and now just sits there trying to connect :confused:

It’s never worked here from 7.0 through to 7.2

Same here. Never worked.

I found a solution for myself as the hub wasn’t working too:
I downloaded Internet Explorer 10 from Microsoft and installed.
I then downloaded and Installed Adobe Flash Player for Internet Explorer.
I launched Cubase 7 x64 in Admin mode (right click “launch as admin”).
I installed the Steinberg Certificates and selected “trusted vendors” as certificate target.
I added on outgoing and one ingoing rule in the windows firewall for the cubase exe file.
Now it is working. Hope it helps!