Huge CPR file size and long save time

Hello

I started working on a large project last month in Cubase 10.5, were the CSH file (not CPR) expanded up to 1.2 GB, with rather long saving (and auto-saving) time up to 20 seconds sometimes.

Nothing special in that session, a few Cubase and Izotope plugins in 4-5 groups + master. Only a LOT of big very long soundfiles (total 40 Gb Audio, 10Gb of Edits in 44khz-24bits + 500 Mb of Images) cut in many small clips I’m reassembling from very detailed recording sessions. I use simple time stretch and transposition here and there. So a very BIG but, I think, simple session.

I used Cubase on and off since SX3 but I have never dealt with such a huge project in there, so probably I optimized my session poorly…

Still, I suspected a bug so I took the chance to update to Cubase 13 to see if it solved it. But it’s still there, even after deleting the CSH, it just returns to after a while, when exploring the subfolders of my session, reconstructing images, etc.

Any idea of what I could have done wrong?

note : I tried to create a lighter backup session to eliminate my original stems and only keep used clips, lighten the load a bit, but Cubase says there’s not enough space on my disc, even if I have 180Gb free on that machine… :man_shrugging:

Thanks in advance for your help !

Julien

1 Like

Well, I had a situation like this before, I now do not trust ARA and DOP anymore.

In my findings it seems that DOP is not smart enough.
If you have a 1GB audiofile and cut it into 100 pieces, and then apply DOP to each audio piece, you end up with a quite significant .csh file.
I presume you then try to make all DOP permanent in the backup otions, Cubase/Nuendo will take the parent file of each of the pieces and render it completely new, for every piece one time, regardless if they all refer to the same parent file.
In this example this will result in 100 new 1GB audiofiles.
No Option to say “Dude, just take the 4 seconds I wanted the declicker on with this little part.”
So, If you did 100 edits to a 2GB Audiofile, your 180GB free Diskspace is not enough.
I now do consolidate each and every part, before and after I use DOP or ARA, which is rediculous, but predictable.

I hope this “helps”, at least might explain the situation you experience.

Cheers,
Dirx

Thanks for your reply !

I’m not sure what ARA means in that context can you be more specific?
(I know what it stands from Google for but not clear if I use it…)

Actually, thinking of DOP when I tried to generate a backup copy, I did try both cases, with and without making them permanent. And the result was the same, not enough space.
But indeed that would not be the smart solution if it created so many useless files…

So I’m not sure, how would you proceed to “consolidate” tracks in a project like this? Is it possible without losing all my clips segmentation and colors? I’d rather avoid using “convert selection to file” because it would turn every track into a single clip, and I still need to be able to move things around and understand what is what.

ARA extensions. Spectralayers, Revoice, Wavelab, etc can use it as connecting software inside Cubase for realtime editing like plugin.
All those edits in it add up the project file significantly

Ok I don’t use any of those, only a few Izotopes in realtime edit (otherwise, just as inserts), so I guess the problem is elsewhere…

So no Direct offline processing?
No Spectral Layers as ARA extension?
Hmmm, sorry, then no clue… :thinking:

That’s the thing that is not clear at all for me since the last few versions of Cubase, what is DOP and what is not DOP, i.e. what prompts a “create a new file”, which I always choose.

When I apply time stretch on a clip (with the ‘sizing applies time stretch’ arrow tool), I assume that’s not DOP, correct? I use a lot of those.

As for things I think are DOP, I almost never apply VST plugins that way. But I do use Cubase’s Pitch Shift process sometimes, less then time stretch but also quite often.

Is there a way to find out in a huge project how many clips have DOP on them, and force to generate a new file instead?
That may fix part of the problem…

Sorry if my question is a bit silly, I’m a bit confused how to call things in English here (I use the French version of Cubase)

If you are using this pitch shift:

then it is applied via DOP.
In the Pool there is a red/black waveform Symbol that will indicate clips with DOP, but also with other manipulation like editing the waveform with the pencil.

I do not know a cool way to make DOP permanent while preserving the edits without generating potentially huge amount of DATA (if you for example used the DOP pitch shift on many little parts of a large parent file).

Bounce selection of the individual clips would leave you without handles, also you would have to confirm the replacement of the clips everytime… but in the end if you want to edit and save fast again, it might be the way to go.

I do not know a cool way at the moment.

Cheers,
Dirx

After more than a month of back and forth with support and dev team, trying to understand why my cpr files kept growing (up to ~615Mb each), it seems we finally found the culprit : automatic hitpoints !

By default (see Audio preferences) hitpoints are generated automatically. It seems that in my case, Cubase generated an enormous amount of them, between long original files and poorly handled copies (when doing DOP and other edits).

The dev team left me with the instruction to go to this page to learn how to delete hitpoints manually. Which is honestly a bit ridiculous because that would imply to delete them one by one with the mouse…

By chance I found forum somewhere online, pointing to a function I never used or heard of (and apparently nowhere to be seen in the official Cubase documentation) : menu Audio > Hitpoints > Delete hitpoints

So almost there :

  1. disable “automatic hitpoints” in audio preferences
  2. open all my folder tracks (to the deepest level)
  3. command + A to select every clip in my project
  4. then Audio > Hitpoints > Delete hitpoints
  5. then command + S to save my project.

The .cpr file went from 615 to 53 Mb — i.e. hitpoints accumulated over the last 3 months represented more than 550 Mb !!! Finally, my autosaves are barely noticeable, and overall workflow feels much lighter. Glad the nightmare is behind me…

For some reason that is not entirely clear, some of my older versions of the same project cannot be reduced with this method, or the size saved is negligeable. I’m still in communication with Steinberg to understand why this is…

Till then, if you don’t use hitpoints (like me), just disable them because they can generate a ridiculous amount of useless data ! And if you do, you can always use that trick to delete the ones you don’t use and save space.

2 Likes

Thank you for sharing your findings, interesting info with another way of getting potentially unnecessary huge .cpr files.
But if I understood your initial post correctly, it was about big .csh files, is this also solved/optimised with the hitpoint thing?

Yes sorry I just realized that I first named the topic huge .CSH file, but also long save time. That was my confusion at the time, I later realized that erasing the CSH had no impact on save / autosave time.

The culprit was really the size of the .CPR, which kept growing over the last 3 months I worked on that session, from 20 Mb when I started to cut my original 30+ hours of recording sessions in January, up to 650 (~40 sec for each save…) last week.
As I explained this was solved by deleting hitpoints.

I didn’t notice impact on .CSH file (yet?), since I got used to delete it every now and then. From there Cubase recreates it after a while, and it starts growing again from 0Mb with normal usage, not sure exactly what is stored in there. Deleting it never really improved my situation, only my session became much less smooth to navigate in some already edited portions. I guess now my CPR are under control I won’t touch it anymore.

In any case this info was interesting, at least for me.
Thank you again for sharing.
I try to keep both file-sizes small and with it the save times.

Cheers,
Dirx

Hi!

Windows 10, Cubase 10.5 pro!
I also had a problem with the size of the .cpr file. Twice already. Took a long time to solve both! I don’t remember the first case for sure, but it seems like the same thing happened there as now!
I tried everything:

  • backup of the project
  • import the tracks one by one into a new project
  • remove hitpoints
  • Reinstalling Cubase
  • etc…
    but the PROBLEM IS A PLUGIN, I think in any case!!!
    In this case, (-Youlean Loudness Meter 2 FREE) did the file growth for me!
    It was used on three channels, I deleted all three, saved the project and instead of 100Mb it became 3Mb!

What is interesting is that I then put it back on all three channels, in the same place, and since then the saved .cpr project file is still 3Mb!
I am guessing that the problem may be related to the AUTO-SAVE function in some way!

I hope I helped someone save time with this! :slight_smile:
Bye