Huge performance difference between Cubase 5 and 9... help

I just got a Cubase 9 copy, I’ve been a Cubase 5 user for years (same installation with all plugins went through several hardware changes) and finally decided to rebuild my DAW environment from scratch: cubase 5 crashed way too often and I couldn’t use 64-bit capabilities and system memory.
These are my specs:

Focusrite Saffire Pro 14 (firewire)
CPU: AMD FX-8320
MB: Asus M5A97 R2.0 evo
OCZ 64GB SSD for the system + HD storage

When the machine had windows 7 on it + Cubase 5 running 96khz 24bit, I could load 3-4 instances of Amplitube 3 realtime (it’s just an example) at very low latency, plus superior drummer and several arturia synths. The CPU stayed at like 30-50% during playback. I never heard a pop, crackle or anything unless I really squeezed the system with too many tracks and vsts. It basically never happened, because I had no need for so much until i finished editing, went to mixing and raised the latency from the saffire control panel.

Now with my fresh windows 10 installation + Cubase 9 96khz 24bit, same latency as before… superior drummer at default settings + 1 amplitube 3 instance and two freezed tracks playing is enough to begin hearing stuttering, popping and crackling. A new project with just the new Retrologue synth on the “Big Keys” settings is enough to start the stuttering if you play a chord instead of a single note.
Funny (or tragic) thing is, the CPU stays on 16-17% while this is happening. Of course the selected asio driver is correct (the one provided by focusrite), I tried messing with asio guard but things only get worse. I tried optimizing the system (services and so on…) but I really think there must be something wrong…

Any ideas please? I can’t go on with my projects but I don’t want to sell and go back to Cubase 5… really. Thank you very much!

Win 10 has different firewire drivers. In 7 I use legacy firewire driver and I installed them on 10 too (but 7 is still my main OS). You can also install those on win 10, but you have to install a special windows legacy firewire fix from MS. This might fix it, google win 10 legacy driver for details. I did it quit a while ago…

If you used Cubase 5 in 32-bit, and now you use 64-bit Cubase 9, it is pretty different. AmpliTube is pretty hungry, btw.