Huge problems with Cubase 13 and EVO 16

Trying to adapt from 8.5 on win7 with 3 Firestudio Projects where things were fairly smooth. Got the EVO 16, and set up. I also have TD-50x as an interface and with that I can hear and play the drums and the audio channels of the songs are heard. Then I tried with the EVO 16, whose driver I’ve installed and firmware updated. When that is chosen as the audio device, after hours of trying I hear nothing. Also there are several midi tracks, which have scores and the only one I can see is that of the TD50x. Control R or going to the menu produces no score for any of the melodic channels. After giving up on that and going back to use the TD50x as the audio, playing the song was now stuttering. such a disappointing day, after great expectations.

Today even worse. In Cubase, select Ambient (Evo16) and ‘no device found’. Look in device manager and it’s not there. Reinstall and still doesn’t appear. Steinberg had said they would help with me setting this up but actually said to go to Ambient chat after efforts proved futile. Then I went to B&H who recommended and were no help. When to Ambient chat and soon realized it was an automaton, paying no attention to what I was typing. Asked for agent, took info and then the window closed. Maybe an email ticket will be answered before Monday, you think? Maybe have to give up and return.