I can´t see my VSTi

Please see the FAQ thread, which hopefully contains the answer to your question. You need to look at the knowledge base article about getting VST2 instruments to appear.

Hello, thank you very much, but all the values are “1”. What must I do now?
Captura de pantalla 2016-10-31 a las 0.07.50.png

I believe you now need to add those values to the vst2whitelist.txt file, as specified in the knowledge base article:

https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/how-to-use-vst2-plug-ins-in-dorico.html

Thank you, I´ve tried it, but I´m still without VSTi.

Can you attach the current state of your vst2whitelist.txt file?

If you have Cubase, look in Vst2xPlugins Cubase.xml in C:\Users<USER>\AppData\Roaming\Steinberg\Cubase 8_64 (I don’t know where in Mac)

Search your loaded VST and copy whole code and put in Vst2xPlugin Infos VSTAudioEngine.xml in C:\Users<USER>\AppData\Roaming\Steinberg\VSTAudioEngine_64
Copy name and ID of your VST like…

play_VST_x64
565354706C6179706C61795F7673745F

Put in vst2whitelist.txt in C:\Program Files\Steinberg\Dorico\VSTAudioEngine\Components.
Put code…

<int name="565354706C6179706C61795F7673745F" value="1"/>

in Defaults.xml in C:\Program Files\Steinberg\Dorico\VSTAudioEngine\Components
Now open and close Dorico. It should work.
vst.jpg

Daniel, currently I´ve erased the items I pasted yesterday, and it is like this:
Captura de pantalla 2016-11-01 a las 23.43.35.png
But I can´t see Kontakt (nor Keyscapes, Omnisphere 2 and a lot of VSTi)

Jerayan, I don´t have Cubase, I use Logic Pro X.

Thank you very much.

Can you check that the VST plug-ins are in the expected location? Ulf describes it here.

Hello, sorry for the delay, but my laptop is at SAT because it had a problem. When I take it with me, I´ll try again

(Sorry for my bad english).

Thank you very much and best regards.

Hello, I´m with my laptop again. This is my VST folder:
Captura de pantalla 2016-11-12 a las 12.20.32.png
I can work with them in all my programs (Max, Logic Pro X, Ableton Live, etc.), except in Dorico. I don´t know how to fix it.

Thank you very much again for your help.

Well, your VST plug-ins are in the right place, which is a good start, but now you need to ensure that the names and GUIDs for all of the plug-ins you want to use in Dorico into the vst2whitelist.txt file, which is described in the knowledge base article here.

This is everything I have in that file, but I can´t see kontakt:
Captura de pantalla 2016-11-12 a las 12.36.35.png
Captura de pantalla 2016-11-12 a las 12.36.35.png
Thank you.
Captura de pantalla 2016-11-12 a las 12.38.17.png

Try removing the first four lines, so that only the Kontakt 16 out version is left behind.

I´ve done it and nothing:
Captura de pantalla 2016-11-12 a las 15.19.09.png

I’m afraid I’m not sure what else to suggest at this point. You could try trashing the VSTAudioEngine folder in ~/Library/Preferences and then restart Dorico to see if that gives it a bit of a nudge.

I did it and now I can see Kontakt 5 16out. It´s something :slight_smile:

I´ve updated Dorico. Now it´s even much better (I really love this program), but I still have these issue:
Captura de pantalla 2016-11-28 a las 1.22.27.png
I can´t see Omnisphere, Keyscapes nor other VSTi. What can I do?

Thank you very much.

Have you definitely correctly added the plug-ins to the vst2whitelist.txt file, and enabled them in the defaults.xml file, as discussed earlier in the thread?

I´ve done, but I´m not sure that I´m doing it correctly. For example, I see this in my default.xml file:
Captura de pantalla 2016-11-29 a las 23.34.24.png
So I take some numbers (I don´t know which VSTi is each of them) and I paste to my vstwhitelist file:
Captura de pantalla 2016-11-29 a las 23.34.24.png
Is this correct? Have I do this manually with all of my VSTi?

Thank you very much.
Captura de pantalla 2016-11-29 a las 23.36.50.png

You do need to follow this procedure manually. Please refer to the knowledge base article for the detailed steps here.