I cannot get LE4 to detect certain VSTs.

Hi everyone.
Ok, I have tried several other DAWs also, to get access to these certain VSTs. They are the Tone Boosters VSTs. The one I really want to use is TB Ferox. An analog tape simulator plugin. I’ve tried EVERYTHING! LE 4 will not detect these plugins. I’ve put them in different locations and still nothing works. I must’ve spent about 5 hours in total now trying to get them to be detected.
I’ve noticed other people having this problem on the web, and the threads always seem to be abandoned eventually with no solution for the person needing the help. Hopefully SOMEONE out there on this forum can help ME this time though?

Thanks in advance.

:slight_smile:

Melek : This is from the tone booster website----How do I install your VST plugins?
Our plugins are not supplied with automatic installation programs. We want you to maintain full control over what is stored and modified on your dedicated audio workstation. Installation is simple: download the zip archive from our downloads page, extract its content and store the resulting VST plugins (which have the file extension ‘.dll’ on windows or ‘.vst’ on mac) in your host’s VST plugin folder.


You’ve got to get the tone booster ‘.dll’ into Cubase by going to

  1. devices
    2.plug-in information
  2. vst plugin paths
  3. add
  4. OK

do a search on your computer for that ‘.dll’
then do the above.

Hope this helps

Jack :smiley: :smiley:

PS: Maybe others can help out here to :question:

Thanks for the reply halljack, but I am not a Cubase newbie. I have tried all the usual ways in which adding VSTs to Cubase should work, and unfortunately, they don’t right now. Like I said, I tried for hours. I really don’t know what else to try. Cubase doesn’t have an alternative way to do this, surely. I’ll try again now out of desperation I suppose…

Melek: Have you tried contacting Tone Booster http://www.toneboosters.com/contact/
Maybe the problem isn’t Cubase

It could be a simple Email exchange might do the trick to activate that tonebooster .dll
I had trouble like this with Toontracks Superior Drummer 2.0 .dll
for a month or so. All of a sudden it worked.
Using DrumCore free it wouldn’t work either until an email was sent to DrumCore.
We all know Cubase has this Activistion Email thing.

Just an Idea :bulb:

Jack :smiley: :smiley: :smiley: