I can't get 6.5 to see B4 VSTi

I’ve got about 85% of my system back online now with N6.5. There no longer seems to be any conflict with the MC Control (no crashes, hangups or the like). I had to dump a lot of old plugs that N6.5 told me were no longer supported.
No problem there. But when N6.5 initalized the VSTi’s it stopped at my Native Instruments B4 (v.2) Organ and said that it couldn’t find the tonewheels and, without them, the B4 would function properly.

I don’t know why it didn’t see the tonewheels. They were in the same folder as the .dll & .exe files for the instrument. Nevertheless, as it offered me the option to show N6.5 the path to the tonewheels, I did. But when I ran down all the links to the tonewheels, N6.5 still wouldn’t acknowledge them. After 2 failed attempts it finished the initialization process and opened.

The B4 showed up in it’s normal slot. But none of the controls worked. Since I had to dump a bunch of old plugs anyway, I shut Nuendo down, removed all of the older plugs from the VST Folder. I tested the B4 in stand alone mode on my desk top and it played perfectly.

I re-launched 6.5 and it opened without any error messages of any kind. I opened the plug-in info folder and found all of my plugs were accepted and working. But the B4 was listed as missing. I created a fresh path for it in the plug in paths menu and updated the folder. B4 is STILL listed as missing.

I use it a lot. So I need to get this instrument working INSIDE N6.5. Can anyone tell me how to get these two to talk to each other again?

Hi Keyplayer,

I can not tell exactly what your problem is , but I can tell you that I have B4II running properly here in N6.5 - so it is possible.

I can only suggest re-installing B4II, making sure that it is properly bridged (I use jBridge) - don’t get me started on why NI will not provide a 64-bit version of this great VSTi :cry:

I recently had the B4 problem tonewheel (copy protection) problem as well.
It made me switch to the Hammond from the Kontakt library. I just wanted to play and not chase computer weirdness.
I feel your pain, I really prefer the B4 as well.

Ollie

Do you mean Vintage Organs? I find this to be a poor imitation of B4II, and it’s out of tune.

B4II works perfectly here with N6.5 64-bit.

Here’s what I don’t get. The 1st error message was about the tone wheels. But it saw the B4. I try to point it to the tone wheels and it won’t recognize them. So I removed the B4 entirely.

I put back the B4 with the cleaned out plug-in folder (see below)
Nuendo 6.5 B4 Missing 02.jpg
You can see it listed right at the top of the VSTPlugins folder! EVERY other folder listed in that plugin folder is available and working in 6.5.

But the Plugin Information Menu LISTS the B4 and then classifies it as missing(???). It’s listed 6th down from the top.
Nuendo 6.5 B4 Missing 01.jpg
So, if it sees it to list it from the same folder that everything else is working in, how is it missing?!!? :question:

Nevertheless, that’s the NON-functioning status of the instrument.
Nuendo 6.5 B4 Missing 00.jpg

Guessing, but it seems like the B4 wasn’t installed properly.
Copying (dunno if you did that) the B4 folder into the 6.5 installation normally don’t work.
It looks like crucial elements of the B4 are missing. Therefore Nuendo refuses to load the plugin.
Again, just guessing …

Search for the B4 .dll’s on your C-drive, and verify that Nuendo is pointing to the correct one.
And remove the redundant ones.
Or re-install the B4.

Fredo

Just did a nerve wrecking complete un-install > reboot > re-install (the nerve wrecking part came from trying to get it re-activated). So now B4 is freshly installed with all the updates. N6.5 still won’t see it. :cry: For a minute, it LOOKED like it was going to work. I saw it load B4 with the rest of the plugs and instruments on star-up. But when the project window opened it still listed the B4 as missing.

Grabbing at straws here, but check the VST 2x Plugin Paths in Plugin Information in N6.5 to make sure that the correct path is included for B4, and maybe ensure that B4 is only installed in one location on disk to avoid confusion.

jBridge?

Good luck.

I got it! I finally figured out which folder was “Active” and now it sees the B4 and all of the other plugs. Then after I got it working , I fired up the MC Control and it had lost the connection to Nuendo (not again!!!). I almost had a heart attack! It’ll be a week tomorrow since this rebuild with a brand new C drive. All of this crap is supposed to be behind me now. Then I did a re-boot and my desktop was scrambled! Again, of this crap is supposed to be behind me now!! :open_mouth:

But once I got everything back where it belonged and fired up N6.5 again with the MC, it looks like things are finally behaving as they should. :sunglasses:

Thanks to all of you for all of your help on this! :mrgreen:

Poor, indeed. The B4 was so much quicker to fire up and easier to automate. It was my last 32 bit only plug, though and I can see the day when you cannot install it anymore coming…So I decided to move on. Shame on NI for that…