I can't make Dorico 3 load, comes up Audio Engine Timeout, ideas?

Dear Anyone.

First of all I installed Dorico 3, tried to start it up and nothing seemed to happen. Looked in Task Manager and it said it was started but it was just sitting there, no GUI or any way of interacting with it.

Then by chance, on another thread here, I found a download with 2 files that had to be added to the Dorico 3 folder to make the program start. So I added them, restarted Windows, double-clicked on the .EXE - and got the loading screen, first time ever. Yay, thought I, now I can see what all thefuss is about.

Except it never got PAST the loading screen. It sat there and sat there and finally came up Audio Engine Time Out and that’s all that ever happened! I’m using Windows 10 with High Definition Audio Codec, if that helps any. If it needs it, I’ve got Asio4All. If that’s the problem, how do I TELL it to use Asio4ALL when it starts, not High Definition Audio Codec? Or could it be something else altogether ?

Just wanna try the thing out!

Yours respectfully

Chris.

Hi Chris, first a bit of explanation. The audio engine of Dorico is running as a separate process, it:s called VSTAudioEngine. So in Task Manager not only look for Dorico but also for VSTAudioEngine and see if that one is running or showing no response.

Then, first I like you to go to C:/Users/yourname/AppData/Roaming/Steinberg and from there zip up every subfolder that has Dorico or VSTAudioEngine in it’s name. Then go to C:/Users/yourname/Documents/Steinberg/CrashDumps and also zip up everything related to Dorico or VSTAudioEngine. Then post everything here please.

Next, try to start the audio engine by itself. Therefore go to C:/Program Files/Steinberg/Dorico 3/VSTAudioEngine and double click the VSTAudioEngine.exe. A splash screen shall appear and after a few secons disappear again. Then it shall run without GUI in the background. Check in TaskManager that the process is there. Then try to start Dorico. Still timing out?

When experimenting, make sure that before launching either Dorico or VSTAudioEngine that you kill any Dorico or VSTAudioEngine process that is still lingering on for whatever reason.

Dear Ulf.
I’ ve posted this somewhere else as well - and thanks for your lovely answer - but I THINK I’ve cracked it! So I’m posting my theory here as well, so you can read it.

Dear Everyone-who’s-getting-the-‘waiting for audio engine’ prob. with Dorico - I can make it do it/not do it to order! Hiding in Windows Applications Roaming, which is a hidden folder which you get to by Opening “Run” using the key combination [Windows] + [R]. Enter %appdata% into the “Open” field. Press “OK” to open the “Roaming” subfolder in the AppData folder. In the Steinberg/Dorico subfolder you’ll find a folder called VST3. That’s the one, I’m pretty sure, Dorico’s trying to find its audio engine in - but it doesn’t always get created right. WHY, I dunno, but it’ll sit there patiently interrogating it and waiting for something to happen!

If you DELETE that, you’re forcing Dorico to fall back to ASIO. So if you install, ASIO4ALL FIRST, THEN delete the VST3 folder, it’ll fall back onto ASIO4ALL and use that. When I say I can do it to order, if you put an empty VST3 folder back in the place you deleted the original one from, you’ll get the error message back. So I’m pretty certain it’s because it doesn’t always create its VST3 folder right!

If I’m wrong with the above I’m apologising in advance - but I’ve done that several times to test my theorem and it’s worked every time thus far. Might be a reason I wot not of for that but the above fits what I’m doing! I can’t do the Steinberg Crash Dumps thing because there ISN’T a folder called Steinberg in my Documents. I’ll show you.

See? The Sion folder’s my lovely Quick Score Elite Level 2, which the creator was too lazy to update to 64-bit, hence why I’m lucky I found yours - it’s pretty close to QSE and I actually am beginning to understand this one too. By the way - can I use 3rd party VSTs with it, including JBRIDGE, so I can use my VSTs from QSE and not have to get a whole new lot?
Yours respectfully

Chris.

Sorry, Ulf, only just seen you want stuff posted. Done the zipfile. Just working out how to upload it here. It’s telling me it’s too large so I’m going to post it on Mediafire and leave you the link here.

BRB!!

OK, the file’s HERE but it’s a non-account so it’ll only stay there until they decide to get rid of it, which is usually a week or so. Hope it - and what I THINK I’ve discovered above - helps!

Yours respectfully

Chris.

Hi Chris,
first of all, thank you very much for the data.
Second, I’m a bit confused, because you say it is running now with you, but the data I’m seeing does somehow not match it.
Third, what is the exact path of the VST3 folder that you are talking about, because I’m pretty sure it is not part of the problem, but I’m happy to be taught I’m wrong. Still, please tell the full path that you are talking about.
And now that you have Dorico running, please do ‘Help > Create Diagnostics Report’ which creates a zip file on your desktop. Please send me that one as well. Thanks.