I hear a Dorico score through the speakers of my monitor and also youtube videos sound through my headphones!

—When Dorico SE 3 is opened, I do Edit, Device Setup and I have the following.
When I click on the Stereo Output drop-down menu, I cannot see anything else than what is selected by default.

—When I click on Device Control Panel, I get the following.

—When in Windows 10, I click on Control Panel, Sound, I get the following window:

PROBLEM:
In the window that opens when I click on Device Control Panel, by unticking the option “Allow ASIO host application to take exclusive control of selected port configuration”, I can hear the sound of the youtube videos in my headphones BUT at the same time, when I go to the play tab in Dorico and I click on the play button to listen to the sound of the score that is opened in Dorico SE 3, I hear the sound of the score through the speakers of my monitor instead of hearing the sound of the score through my headphones!!
However, I must be able to hear everything through my headphones or everything through the speakers of my monitor BUT not one sound (youtube videos sound) through my headphones and another sound (the score opened in Dorico) through the speakers of my monitor (while still having my headphones on my head)!!

The reason this problem happens is, I assume, because in Edit, Device Setup, Device Control Panel, the section Output Ports, Device name only has the speakers for my monitor listed as: PHIL BDM4350 (Intel®DisplayAudio).
Instead I assume that it should also have my headphones listed as Realtek HD Audio 2nd output (in Edit, Device Setup, in Stereo Output, they are stated as: Realtek HD Audio 2nd output 1, Realtek HD Audio 2nd output 2, it is my headphones I believe).

It seems that Dorico is not smart enough to spot my headphones although it spots the speakers of my monitor.
The problem is that, when I have my headphones on my ears, the speakers of my monitor should NOT sound anything, as the sound should only reach me through my headphones!

So, again, I want to be able to hear the sound (of both youtube videos or a Dorico scored played back) either only through my headphones or only through the speakers of my monitor when I use Dorico and youtube videos.

END.



—When Dorico SE 3 is opened, I do Edit, Device Setup and I have the following.
When I click on the Stereo Output drop-down menu, I cannot see anything else than what is selected by default.





—When I click on Device Control Panel, I get the following.



—When in Windows 10, I click on Control Panel, Sound, I get the following window:



PROBLEM:
In the window that opens when I click on Device Control Panel, by unticking the option “Allow ASIO host application to take exclusive control of selected port configuration”, I can hear the sound of the youtube videos in my headphones BUT at the same time, when I go to the play tab in Dorico and I click on the play button to listen to the sound of the score that is opened in Dorico SE 3, I hear the sound of the score through the speakers of my monitor instead of hearing the sound of the score through my headphones!!
However, I must be able to hear everything through my headphones or everything through the speakers of my monitor BUT not one sound (youtube videos sound) through my headphones and another sound (the score opened in Dorico) through the speakers of my monitor (while still having my headphones on my head)!!

The reason this problem happens is, I assume, because in Edit, Device Setup, Device Control Panel, the section Output Ports, Device name only has the speakers for my monitor listed as: PHIL BDM4350 (Intel®DisplayAudio).
Instead I assume that it should also have my headphones listed as Realtek HD Audio 2nd output (in Edit, Device Setup, in Stereo Output, they are stated as: Realtek HD Audio 2nd output 1, Realtek HD Audio 2nd output 2, it is my headphones I believe).

It seems that Dorico is not smart enough to spot my headphones although it spots the speakers of my monitor.
The problem is that, when I have my headphones on my ears, the speakers of my monitor should NOT sound anything, as the sound should only reach me through my headphones!

So, again, I want to be able to hear the sound (of both youtube videos or a Dorico scored played back) either only through my headphones or only through the speakers of my monitor when I use Dorico and youtube videos.

END.



Welcome to the forum, Michael. I’m not an expert on the vagaries of getting built-in Windows audio hardware to play nicely with Dorico, but while you’re waiting for my colleague Ulf to drop his pearls of wisdom your way, in the meantime you might try installing ASIO4ALL and giving that a go. Try choosing that in Edit > Device Setup instead of the Generic Lower-Latency ASIO Driver, and see if that gets you any further.

Hi Michael, I think it has to do with some settings on Windows’ side.
On your taskbar is the little speaker icon, right click on it and choose ‘Open sound settings’.
Select ‘Realtek HD Audio 2nd Ouput’ and then ‘Device Properties’, then scroll down and choose ‘Additional device properties’, another little windows appears. Click on the ‘Advanced’ tab.
What are the settings in there? Is the option ‘Allow applications to take exclusive control of this device’ ticked? If so, untick it.
And what is the sample rate set to under ‘Default Format’? Make sure it is same as the setting in Dorico.

If you still can’t get it to work, please do ‘Help > Create Diagnostics Report’. That creates silently a zip file on your desktop. Please attach it here. Thanks

Hello Ulf,

As this forum does not seem to allow me to put more than 3 attachments by postings, I am going to have to do several postings. Sorry about that but that is apparently how this forum works.

—After following exactly the instructions you gave me, it did not work meaning I still have the sound of the youtube videos (using Firefox) coming into my headphones and, while Dorico is also opened, when I play a score in Dorico, the sound comes through the 2 built-in speakers of my 43” monitor.

In Dorico, doing Edit, Device Setup to check it out, I noticed that this time it indicates not my headphones but the speakers of my monitor.


Here in Device Setup, normally I think it should show the headphones, not the speakers of my monitor as it shows here.
When I click on the drop-down menu for Stereo Output, I only see the option shown (PHL BDM4350 …).
Same for the sample rate, only 48000 is shown when I click on the drop-down menu.


—Right-click speaker icon on the taskbar, select Open Sound Settings and I get the following.

—When I click on Device Properties, I get the following.

(to be continued as there is a limit to 3 attachments!)

(continued from Par 1!)

—Clicking on Additional device properties, I get the following two pictures.
Image 7 - Device Properties, Advanced option tab - 1 (after Ulf’s instructions applied).jpg

and
Image 8 - Device Properties, Advanced option tab - 2 (after Ulf’s instructions applied).jpg

—To answer specifically to your question.

Click on the ‘Advanced’ tab.
What are the settings in there? Is the option ‘Allow applications to take exclusive control of this device’ ticked? If so, untick it.
And what is the sample rate set to under ‘Default Format’? Make sure it is same as the setting in Dorico.

Before applying your instructions, the settings were as follows.
Image 9 - Device Properties, Advanced option tab (BEFORE Ulf’s instructions were applied).jpg


(to be continued in Part 3! as only 3 attachments are allowed per post!)

(continued from Part 2)

—After applying your instructions, I untick “Allow applications to take exclusive control of this device”
and in Default format, I changed the option to:
2 channel, 24 bit, 48000 Hz (Studio Quality) (as it was with 192000 Hz, the rest being the same).


—You say:

If you still can’t get it to work, please do ‘Help > Create Diagnostics Report’. That creates silently a zip file on your desktop. Please attach it here. Thanks

I have never done a Create Diagnostics Report before. What you say: Help > Create Diagnostics Report cannot allow me to do this report. Could you be much more specific on how to do this diagnostics report. I tried something and I got the following but it could be saved only in html, not in zip and when I check the html, various small icons were not even showing up. Is it what you want but you will have to explain me how to get a zip version of it because File, Save As only allows to save it as an html file.
Image 10 - Diagnostics Report (I assume).jpg


END.

Hello,

I would have preferred to show the pictures directly in my posts but I could not see the way, as I did that quickly. Is there a way to do that in this forum in a post?

Kind Regards
Michael

From within Dorico, click on the Help menu, and then click the Create Diagnostic Report menu option. It won’t do anything obvious, but if you then minimise or close Dorico you should see a file called Dorico Diagnostics.zip on your desktop. Upload that file here.

Hello Ulf,


I reverted back to my previous settings and I will wait for your coming feedback.

As even with the changes you asked me to do, I have the same problem that is the sound goes to my headphones for the sound from the videos on youtube (using Firefox) and the sound to listen to a Dorico score goes to the speakers of my monitor despite the fact that I still have my headphones and therefore I expect to receive the sound of the Dorico score also in my heaphones.
I listen to the sound of the videos or the Dorico score, one after the other, not at the same time.

Thanks for your help on solving this issue. Very much appreciated.


Kind Regards
Michael

Hello Ulf,


Following pianoleo’s feedback on the diagnostics file (thanks leo), here it is.
Dorico Diagnostics.zip (312 KB)
Kind Regards
Michael

I’ve posted about this several times before (I swear I’m not affiliated with them), but I use a donation-ware program called Voicemeeter. As it can handle multiple ASIO streams at once, it sorta magically solves issues I used to have with multiple audio programs running at the same time in Windows.
https://www.vb-audio.com/Voicemeeter/banana.htm

If you want to download it, set your outputs from Windows and all audio programs to Voicemeeter Input, then in Voicemeeter set the Hardware Out to whatever output device you want by clicking the little A1 arrow next to that text. As long as all your sample rates match, you should be able to get your headphone output working for everything in Voicemeeter.

@Fred: Yes, that Voicemeeter might help, but it is also possible without it.

@Michael: Many thanks for your effort in showing what you did.
Now I see. So in the Windows’ sound settings indeed that ‘Allow applications to take exclusive control’ option was ticked. Also, your sample rate there was set to 192000Hz, which was not matching the Dorico setting.
Please set it again to 48kHz and untick the ‘exclusive’ option.
Then open in Dorico again the Device Setup dialog and click on the Control Panel button. In the new little window that appears, in the middle is the list of output ports. There shall now also be an item called ‘Realtek HD Audio 2nd output’. There is a little radio button in front of it, please check it and close the dialog. Then the Device Setup dialog shall also show the Realtek as output. Close the device setup dialog, and for safety, close Dorico and restart it. Then Dorico shall play out via your headphones.

Hello Ulf,


Following your instructions given on Tue Apr 07, 2020 4:32 pm, it now works fine that is I do hear the sound of videos from youtube using Firefox on my headphones as I did previously but now I also hear (as wanted) the sound of a Dorico score in my headphones when I click on the playback button. So, the problem is now FULLY SOLVED by only just following your instructions.

Just a remark. When you say:
“Then the Device Setup dialog shall also show the Realtek as output.”
It only showed Realtek as an output only after I had restarted Dorico, not before.

Many thanks for your help on this issue, as it was an issue of basic use of Dorico with videos on youtube and I really wanted to have this issue sorted out and, thanks to your help, it is now sorted.

Thanks to the other posters who provided suggestions that I did not need to test but it is always good to get options, just in case. Much appreciated.


Kind Regards
Michael

Hi Michael,
I’m glad to hear it’s solved now for you.
Regarding the restart, indeed, there is still a little glitch there, but with the next update that also will be a thing of the past.
I sometimes forget that there are bugfixes we made, that are not in the public version, yet.