I hear no output for my ur22c guitar in cubase 10.5 elements

i have cubase 10.5 elements and have connected the cables : usb from ur22c interface and outputs (L\R ur22c) to powered monitor speakers. When i set up a project in cubase 10.5 elements i am adding a track with inputs selected for the ur22c. i also have selected the studio output to be yamaha steinberg usb asio driver in studio → studio setup.

when i am attempting to play the guitar and record something I hear absolutely nothing. no volume from the guitar at all. i have enabled metronome and i can hear those clicks. I have also dragged in a wav file as a track and that also plays and i hear audio.

the guitar track from the ur22c interface shows a signal when i go to studio → mix console (level lights up when i strum the guitar).

i feel this is a simple thing, but i am not getting any output signal volume at all.

thanks in advance

Hi and welcome to the forum,

Is your guitar plugged to input 1 or 2? Did you enable Ho-Z? Did you add mono Audio track? Did you select the proper input? Did you enable Monitor button on the track?

the guitar is plugged in to input 2. i’ve tried hi-z on/off). in cubase i have set the inputs to bus Name UR22C line 2, with audio device Yamaha Steinberg USB ASIO on Device Port UR22C Input 1/2) ur22c. Monitor button has been enabled on the track. still I hear nothing from the speakers


How is the output set over the track, please?

I just wanted to say that after i have went thru and registered my license, installed a separate VST plug-in, and deactivated “direct monitoring”, as well as using helix native plug in. I was able to successfully hear my guitar track thru my monitor speakers and with the appropriate IRs.

i believe it was mainly the registration thing that was hanging me up though previously.

Maybe the deactivation of direct monitoring has “fixed” your issue… what is your Mix dial doing on the UR22C? All the way to the right? Then you would hear only DAW signal and with direct monitoring on… no input… dial it to the left to add dry input signal to the output…