I LOVE CUBASE 11 but small complaint about support

I’ll get right to it. Since 2018 The program kept randomly freezing, stalling, during exporting (rendering) out my master. Only way out would be a control + alt + delete, reset. I googled and noticed others (very few) were having the same issue but no concrete answers to fix it.
I tried:

-checking for bad plugins
updating drivers, etc…

Anyway, I finally reached out to Steinberg for support and was promptly told that my PC was just too old .
(side note: I built the PC custom about 7 years ago. on an i7 2600k chip with 32gb RAM. It’s tweaked and still screams).
Now, Every other program I use works FLAWLESSLY on this system so I had a hard time accepting that answer. I was going to put my ego aside and build a new PC.
Then Cubase 10.? came out. PROBLEM FIXED!! No issues. I mean works PEFECTLY!

So, I’m VERY grateful that the issue was not my PC BUT Steinberg really has to get better with dealing with bugs. Especially if it only effects a handful of users. We paid for the upgrades like everyone else. I’ve been a user for at least 10 years now.
Possibly Steinberg have improved because version 11 is SOLID for me!!!

So I’m still in love with Cubase :slight_smile:

Cubase is a significantly more complex program than other DAWs.

The issue very well could have been your PC. Dealing with bugs is a tricky thing, Every PC has a different user, different OS, different OS version, has different drivers installed, has different Plugins, different plugin versions, has Windows Update disabled and missing key certificates, different hardware, different CPU, user tweaked BIOS, viruses, proper cooling vs heat problems, graphic card brands, updated graphic drivers vs non-updated, good RAM cards vs lemon RAM cards, hard-drive corruptions, etc, etc, etc, etc.

The variables are infinite.

My computer is probably older than yours, I’m running Windows 7. It has ran everything from Cubase 4, to Cubase 8, Cubase 9, Cubase 9.5, Cubase 10, Cubase 10.5 and now Cubase 11 with a slight OS hack. Mostly without problems. At least not - completely not working at all - kind of problems. It’s always worked pretty darn good with a crash here and there.

When I have reached out to support, I have got extensive help and the system diagnostics level.

Just curious: Which version was the flaky one on your system?

Started pretty much with 10

We had very different experiences. Happy the issues was corrected though.