iC Pro crashes as soon as I try to enter IP address

I just got a 6th gen iPad and downloaded iC Pro. When I first tried connecting to my desktop DAW (Win 10 Pro x64 1909) running Cubase Pro 11.0.41 (with Ski installed and added in Remote Devices and Bonjour installed) I had iOS 14.6 on my iPad. iC Pro didn’t see my computer so I tried adding the IP address shown on the SKI tab in Studio Setup. I couldn’t connect.
I then got a notice that iOS 15.1 was available to be installed so I went ahead. Now iC Pro crashes as soon as I try to input the IP address under 15.1.
I think the connection problem is on my desktop side. I can ping the IP address of my iPad and it connects. I downloaded Mocha Ping Lite and tried pinging my DAW from my iPad but wasn’t able to see it.
I also can’t connect from Firefox on my Android phone using the IP address from SKI. I had been able to do that in the past before I moved to my new flat. I think I have specified more security when I set up my connection to the wireless router I’m using (I have a roommate at my new place and am using his router).
I’ve tried loosening up my connection security in Windows: Cubase is allowed in the firewall settings, and I’ve allowed remote connections.
So any suggestions on what I need to do so my iPad and iC Pro can see my DAW computer so I don’t have to type in the IP address and make it crash?
Thanks.

I specifically didn’t update my iPad to 15 that I use ic pro on. Steinberg never seem to answer any questions to do with this app. The support is zero. I’ve just built a win 11 machine and just accepted all prompts to allow Cubase and ic pro connected to the pc name without me needing to put the up in. When I’m home next week I’ll try it with my other iPad which is on iOS 15.

1 Like

Thanks for the response. I think I’ve at least figured out the connection part and will fix that tomorrow (dual NATs apparently). I think my best case scenario is that with the connection fixed iC Pro will find my computer so I don’t have to try to manually input the IP and cause the crash. Fingers crossed…

I hope you get it going. IC Pro is long overdue an update. Others are always updating their apps. Avid and rme to name two.

1 Like

Update: I managed to figure out my connection problem and fix it. Both the modem and router were performing NAT (Network Address Translation) and that was blocking my connection. Once I disabled the router NAT, I could connect. Once I could connect, iC Pro could see my computer so I didn’t have to type in an address, so it didn’t crash. Now it’s working as it should, as far as I can tell so far. So the main problem was caused by the guy who set the router up for my roommate before I got here, but still Steinberg and/or Apple (probably more Apple, but Steinberg needs to patch iC) are responsible for the app crash when trying to do a normal function of the app.

Yes, there are other threads here that have the same topic. After iOS 15, the app crashes when using the keyboard for input. All contacts with Steinberg said: “we will pass the information to the development department” - no reaction so far. This is incomprehensible, especially since the app is still available for purchase. For me, my iPad has at least saved the start data, so that the app itself works. Searching for shortcuts or entering text does not work.

I figured it out. Don’t attempt to type anything into the IP address area. When Cubase is launched on the Mac that you want to pair the iPad (or iPhone) with, the computer’s ID name will get displayed on IC Pro. Press that name selection and IC Pro will launch.