Iconica Sketch_too much reverb

Hello, I’ve just bought the Dorico update to 5.1 version and tried Iconica Sketch library on some Bruckner scores. Compared to HSE it sounds more natural, but much less clearly in fast passages, e.g. in legato, pizzicato or détaché strings. There’s just too much reverb and the individual pitches are blurred. HSE is better for identifying individual sounds auditively, but it sounds worse overall.
I tried to mute reverb in the mixer section, but the reverb is still very pronounced. Is there a way to turn off the reverb or is it just baked into samples?

You may want to bypass the REVerence reverb in the FX channel in the Mixer for starters, but you cannot change the fundamental reverb in the Iconica Sketch patches. Iconica Sketch is a new mix of the four separate mic positions available in Iconica Sections and Players, designed to provide a punchy sound but with some of the room as well.