Identical Double midi notes recorded!!!

I’ve just noticed that whenever I record a midi part on an instrument track and open up the midi editor ALL the recorded notes have identical doubles sitting below them! What the hell is this about. Every time I work I have to remove them. I’ve checked the preferences and can’t find anything amiss…

Can anyone throw any light on this please? And suggest how I can remove this unwanted, unrequired, unnecessary and totally annoying thing.

Also re Parts get track names… often I start a midi track with a particular plugin, and the midi parts get this vst label. However when I change the VST, which is all the time when I’m working, the parts still remain with the old, and now unwanted name. How do I change this? At the moment I am moving the parts onto a different midi track and then back again to get the parts relabelled correctly. This doesn’t seem right.

Both these issues are a real workflow killer.

sometimes there are two midi ins in your setup, one windows midi and one generic, try disabling one.

Check you controller does not have two idendical or overlapping zones set up.

Hippo

don’t use ‘All MIDI Inputs’

Aloha S,

I noticed the pic in your avatar is that of someone holding a guitar.
Are you using a guitar synth as a controller?

I ask because over time as intonation slips, guitar synths can have this problem ‘big time’;
so for many years Cubase has had a ‘Delete Doubles’ function.

This function might help in your situation.

Go to Menu—>MIDI—>Functions—>‘Delete Doubles’

BTW
Even if you are using a keyboard as a controller, this function might help.
But as someone already posted, this should not be happening with a keyboard controller.


HTH
{’-’}

Thanks that did the trick. For some unknown reason CB6 now includes an additional Windows midi function which needs to be disabled.

Any suggestions on the track names???

Bob

lol, that had me sniggering for a while :laughing:

JMCecil, excellent reply, though I prefer Joe, or even (get ready) Mary. :wink:

Additionally, Sonic, you could change all part names on a track by editing the track name and hitting ctrl-enter. (that might be wrong, I’m on a Mac where it’s command-enter).

I’ts ctrl-enter indeed on PC.

What Steve said.

Sorry about the smarty pants response.

There are a lot of different ways to rename tracks/parts/events/clips/regions etc… Sometimes you can rename a bunch of them. Sometimes you have to do it item by item. If you want to rename a part though, make sure you have the info line visible, select the part/event you want to edit and you can edit lots of stuff for the select item in the info line.

In this case I’m not being a smarty pants. This would be a good reason to open the operations PDF and search for “rename”. There are literally dozens of different ways.

If that was right, it would be a workflow killer for sure! :smiley:

“Parts Get Track Names” (PGTN) is selected, seem to only affect moving a part from one track to another.
(Which seem right to me.)

If you want to rename a track AND automatically rename all parts on that track then, edit the name of the track, but when you hit [Enter]/[Return], also hold down any of the modifier keys (Shift, Ctrl or Alt). This will replicate the name of the track to all parts as well, regardless of th PGTN state.

Please note that this resets all part names on the track.