If Mix Console error crash Cubase 10 when loading older projects with Halion Sonic SE

… and it happens with projects containing Halion Sonic SE VSTi, or Halion Sonic VSTi, then you may have been hit by this “bug”. Read how to solve the problem below.

I tried a lot of things to get rid of that ‘Mix Console’ crash error in Cubase 10 Pro, including but not limited to:

  • Disabled Hub in Preferences = no change
  • Started Cubase without sound card = no change
  • Flushed Preferences = no change
  • Updated iLok & Elicenser = no change
  • Updated Halion Sonic SE = no change

Btw, I recommend you to first try the above-stated points.

None of the above solutions worked for me, however.

The solution that worked for me:

Make sure you don’t have more outputs activated than loaded instruments in Halion Sonic SE slots!

After a lot of trial and error tests, I finally managed to get rid of that nasty Mix Console crash error when loading older Cubase projects in Cubase 10 Pro :slight_smile:

Open the Cubase project in the older version of Cubase, preferably the one used to create the project.

If you have been used Halion Sonic SE as a multi, AND there are more outputs activated from Halion Sonic SE to mixer than actually instruments in Halion Sonic SE - it will crash when trying to load it in Cubase 10 Pro.

In other words, do NOT add output channels from Halion Sonic SE if they are NOT containing instruments.

All this is valid for a rack loaded Halion Sonic SE instances.

So, if there’s more output activated than loaded instruments in Halion Sonic SE slots, it will crash when trying to open in Cubase 10 Pro.

Cubase rocks!



Do I understand right you had a crashes while loading an older projects with HALion Sonic SE and multi-outs? What do you mean by

do NOT add output channels from Halion Sonic SE if they are NOT containing instruments

, please?

Yes, I had that problem, and solved it.

Simple rule: When you in VST Rack click on ‘Activate Outputs’ (img 1) for Halion Sonic SE, check (activate) the outputs ONLY for loaded instrument slots in HSSE (img 2).

That’s it.


Then the crash you had must be in HALion Sonic, not in Cubase. Cubase doesn’t know what instruments are loaded in HALion Sonic.

Could you share one of the crash dump file, please?

I cannot reproduce the crash here on my side.

I thought the same thing, but I have tested it multiple times:

Create a project in previous Cubase version, say Cubase 6.
Load a Halion Sonic (SE) VST and load instruments in several slots. Then activate outputs but add more outputs than the actually loaded slots in Halion Sonic (SE).
Save file.
Open fresh instance of Cubase 10, do NOT load any projects before this one.
Try to open it in Cubase 10. It will hang at ‘Loading MixConsole’.

I’ll send you the link to dump file and Cubase 6 Project file in PM.


Thank you for sharing the *.dmp file and even the project.

I can load the project on both my machines Mac and Windows without a crash to Cubase 10.0.10. I can see, not all HALion Sonic SE slots are loaded, but all Outputs are in use (attached screenshot), so it seems to be the right (faulty) project.

Unfortunately the dmp doesn’t point to anything specific. Actually it doesn’t point to Cubase at all. There is only a kernel32! entry in the stack.

So I’m sorry, I don’t know, how could I help to avoid these crashes.

Check the new project file I’ve sent in private please. The unaltered.


The project also haven’t crash on my system. But I don’t have M1 and BPM plug-ins installed.

The dmp file pointes to the exactly same thing:

kernel32!TestResourcesDataMatchEntry <PERF> (kernel32+0x0)

Yes, I’m suspecting that as a project including the HSSE was saved in the 32-bit state in the original Cubase 6 file, the problem occurs when opening in a 64-bit environment.

The error in the dump file is of a generic nature, there’s nothing I can do without the help of Steinberg techs at this phase.


Thank you!