Im starting to get seriuslty mad with steinberg.

I added a case for 9.5 before Christmas. It’s about changes in transport from cubnase 8 to 9.5 and it might be a bug or it might be a design change. (Not documented) And the idiots closed the issue as solved without even reply.
Anyone else that have got their cases closed as solved without response?

So hmm… What’s your issue with the transport?

I can not do transitions between different shuttle speeds in a consistent way. (cubase 8 did)

You mean the removal of the shuttle wheel? Have you tried mapping some keystrokes to it?

It is the same “bug” for both key events and for generic midi events.

What’s the bug?

The “bug” is that transport has changed from 8 to 9. Im not sure if 8.5 has it or not.
To demonstrate this bug you need something that can send midi files to your cubase.
Import the shut.xml to a generic remote controller. Same file works with old and new cubase.
Send the transport.midi to your cubase.

It start to runing forward in slow pace and accelerate to high speed. And then it stops.
It then do the same in reverse. On cubase 8 it runs as it expected
but on newer like cubase 9 it starts ok, then it stops and then it starts again and so on.
This can also be seen on the transport play knob that turns green.

There are also reports on same bug when using key commands.
shut.zip (2.04 KB)

Well, if you want to post a repro sequence, please do, or link to the other reports you mentioned. That’s what’s needed to test. A Generic Remote plus a midi file are not reliable for testing, because the tester has to be able to reproduce it independently.

This is not a issue report, the issue is sent though steinberg support. And the two files is everything a engineer need to
have to reproduce the issue. This thread is about steinberg support, or lack of support and their closing off issues as “solved” without any action. It they worked for me that would have been a cause to get fired. As the managers see this as customers that have got support when did not.

Then you must be talking about the fact that the shuttle/jog wheel was removed. This was a design change, and not a bug. https://www.steinberg.net/forums/viewtopic.php?f=226&t=90556&p=735640

Certainly not in https://www.steinberg.net/forums/viewtopic.php?f=226&t=90556&p=735640#p735640 you also say

And they are also available as functions in generic remotes, however they have changed behaviour so you can not go from 1/2 speed to 1/4 in some random cases. Or any other speed changes. It seems to be timeing related and there is no timer reset functions.

If there’s a bug, I want to test it and find it. I use the shuttle controls a lot, both with keyboard shortcuts and with a dedicated CMC-TP. I have not experienced the glitch you’re talking about. If you can come up with a way to reproduce the problem, I’ll try it out.

If it’s only happening with generic remotes, are you saying it only happens when using a GR?

It happen with the key commands too. There is some shuttlexpress users that have written about it here.

  1. You need cubase 8 and cubase 9 or 9.5
  2. You need something that can send midi files. It can be a second computer with a midi connection to the “target cubase”.
  3. Install the shut.xml as a generic remote. Create new and load.
  4. Define the remote on target to use the same midi channel as your are connected to secondary computer.
  5. Copy the transport.midi to the second computer.
  6. configure the secondary computer to send content of transport.midi to the device connected to “target cubase”.
  7. Open a empty project on the “target cubase.”
    8 Start to send the transport.midi on the other computer.
  8. Verify that it works. Eg that there is something that happen with the transport functions when seding the midi file. The first event is a slow play. Look at the project time. It should move. If it does not something is wrong with the setup of the midi ports.

10a (cubase 8), the cursor moves forward slowly and get up to high speed, slows down and stop. After that it does the same in reverse.
10b (cubase 9), the cursor moves stops, starts, stop starts etc, and goes back.
11. Try 10a and 10b several times. they are consistent within cubase version, but 8 and 9, 9.5 have very different movement.

To nail it down, why is it stopping in 9, 9.5 no stop command is sent, and what should I send so it does not.

I’m trying to decipher what the exact bug is. It appears you are saying that playback stops after using a shuttle command during playback. Is that correct?

It some times stops when you go from one speed to a other, some times it works.

I see what you saying, Cubase requires the release of one keystroke, then needs a few milliseconds before it can process another one.

The repro is quite simply:
Using Key Commands, invoke shuttle at various speeds
Try to rapidly switch between speeds

Observe that it is required to release a keystroke, and wait about 50-100 milliseconds before htiting the next.

Well. this is about midi not about keys even if the root cause is the same.