Import a WAV file with a different rate than project settings = NO SOUND? What?

It used to be that if my project settings were 48k 24bit that I could import wav files that were 44k or vice versa. I could have a project set to 44k 24bit and import a 48k file. Cubase would handle the rate differences. Now in 9.5 if I import a wav file that is not the same exact rate set in the project settings NOTHING will play in the song. This includes any VST/MIDI tracks. It’s just silence. If I change the rate of the wav file to the same rate in the project settings and THEN import the wav file everything plays fine.

  1. It is annoying and time consuming to have to figure out which files are at a different rate.
  2. It is annoying and time consuming to have to change the rate of that file in a project.

Is there a setting somewhere that can turn this off or is this an issue that has now been fixed in 10? I’m getting so fed up with Cubase and the issues that I have with constant audio dropouts and things like this that I am about ready to switch to a new DAW despite using Cubase since the very first version came out a million years ago.