Import flow crash, open two projects hangup

When I try to import a flow, it stops at 57% indefinitely and when I cancel the import the ball starts spinning and Dorico crash.
When I instead open a second project Dorico hangs indefinitely without crashing but everything is greyed out.
Then I tried t
Dorico (1.6 MB)
o open one small flow and import another small one, that worked.
Then I tried to open the first small one and then open the second small one, then it hangs again.
I include the diagnostics, hoping some help will arrive.

Today it took a long time but I managed to import a flow. But D still hangs when I try to open a flow as second project so I have to force quit. Perhaps the new update will fix this.

The new update did not help, I am still unable to open a second flow. This is a real bother as I urgently need to import stuff from one project to another. As I said it does not crash, it just hangs and last night I left it for half an hour before cancel/crashing. Here is the last diagnostics, hope I can get some assistance.
Dorico (1.4 MB)

Unfortunately the diagnostics won’t help in this case because Dorico isn’t crashing, so we can’t see what’s going on. Please attach the project you’re trying to import into, and the project containing the flow you’re trying to import, and specify which flow(s) you’re trying to import, so that we can try this for ourselves and see if we can reproduce the issue.

Thank you, I’ll WeTransfer it right away.

A complement: Suspecting that it might have been the fact that the second one was saved as a flow and not as a project or that my first big file was the reason, I just tried to open two small older projects but the same thing happens, its still hanging.

You sent me two projects, Bengt. I first opened New Beer_2022 - New Beer - Sthlm-Umeå.dorico. Then I chose File > Import > Flows and chose New Beer - New Beer - Melody 10 - jobba.dorico. This project contains just one flow, New Beer - Melody 10 - jobba. I clicked OK to import it, and it imported just fine.

Can you spell out for me the exact steps you’re taking that result in Dorico hanging?

OK. The one with just one flow was saved as Export Flow, but I suppose a saved flow becomes a project.
I’ve tried a number of times and each time it hangs. Same when I tried with two small projects. But as I said in my first post importing worked but it took a very long time. Its when I try to OPEN a second project that it hangs. Now I just start Dorico, from the hub I open Cool 2022 and then at once open from open recent Melody 10. Dorico hangs w everthing greyed out. I’m running a M1 w Note Performer. Maybe I should try without Rosetta?

If you want to import music from one project to another, you don’t need to open the second project directly: just open the project into which you want to import the flow, then choose File > Import > Flow and choose the project that contains the flow you want to import.

Yes but in this case I did not want the whole flow, I just want to copy some things from it. Can you open two flows? Btw I just tried without Rosetta but that did not make any difference (unless its necessary to restart the computer when changing that)

Yes, I can open both of your projects at the same time with no problems. When asked whether you want to activate playback for the second project when you open it, try clicking Do Not Activate. The project will then open without being set up for playback, but you should still be easily able to copy and paste from that project to the original one.

I don’t get a chance to click that, it hangs before that.
So I tried to put the first project to Silence and then open the second but it hangs nonetheless.

That’s very odd. Can you run Activity Monitor, choose Dorico in the list of running processes, and from the menu in the toolbar choose Sample Process, then zip up and send the resulting zip file.

I just thought of that. /this is Activity after 15 minutes of hangup, it looks more or less the same now after 40 minutes of hangup:

I\m not sure which one is Sample Process in swedish, could it be Get spindump? Or

Here is the spindump, hope that’s what you want: (379.9 KB)

For some reason, after a couple of weeks, the activate button now appears and I can open the second project. I tried to open with playback activated and that also works.
So I’m still puzzled but happy. Thanks for trying Daniel.