Import midi file with tuplet of 1/32


Can someone explain me how to correctly import from Cubase a midi file with tuplet at 1/32?
After the import the quantization is not ok!

I attach a picture showing the issue:
left is cubase, right is Dorico.

What am I missing? Do I need to set a resolution for the import?

PS reimporting the midi file in cubase works, so the midi is ok.

Could you attach the MIDI file itself, or a snippet of it? You’ll need to zip it up.

Paul is the authority on quantization issues, but I wonder whether it might be that Dorico is making some assumptions about the units for tuplets that you’re likely to see, and it doesn’t get down as short as 32nd notes.

Yes, I think it’s quite likely that we don’t currently have the option for quantising tuplets that small. Note that quantisation in Dorico is a very different type of operation to quantisation in most DAWs. In a DAW you force notes to be quantized to the current tuplet setting. In Dorico the quantization is adaptive, in that it evaluates many different tuplet combinations and it tries to find the one that is the best balance of the being a good fit and being the simplest representation.

If you have the notes quantized exactly as you like in Cubase then I think it would be better to export MusicXML rather than MIDI.