Import MIDI Question


It appears that every time I import a midi file, it creates many tracks for just one instrument. Is there a way to prevent this?

Below is a picture.




Could you send a screenshot of your MIDI File > Import settings from preferences?

Maybe even the MIDI File itself could help. Is there a MIDI Channel rotation?

Here is a pic of the midi settings (haven’t changed anything here). It seems that every midi file I open is like that, so I don’t think the file is the culprit. I’m on Windows 10.

Me Rompiste El (24.2 KB)

It’s not an import problem as far as I can see That’s how that midi file has been saved.

I would say so too.

Maybe it’s the way Logic exports midi? Every time I open a midi file that people send me, it opens like this.

Isn’t it MIDI Polyphonic Expression (MPE) record?