Import track - colors change

When importing a track or tracks, the track color change. Is it possible to avoid that ?

Its particularly annoying when I import a large punch of tracks at the same time. Then I need to sit and re-color all the tracks.

Dr Tolle

Hi,

Does it change to the default color? Or does it change to the color from the original project?

Do you import the tracks to already existing track (so just the data) or do you import to a New Track?

it changes to default color. (according to the colors that are set in the project that the tracks are loaded into)

now I am not sure I understand your second question, but i simply use ‘import/track archive’.

What happens if you import tracks like this. Does it keep the original colors that was saved with the tracks or does it change the colors ?

Best Dr Tolle

Hi,

In the Import Options dialog you can choose for every single track if it should be imported to a new track (a new track is created in the project) or to an existing track. Which option do you choose?

To be honest I don’t think that the track color is stored in the Track archive.

Hi again.

In the dialog box for importing tracks I only tick on ‘import’. I havent tried ‘new track’ and to be honest I couldnt figure out how it worked when testing it today.

Regarding colors. Yes it also seems to me that colors are not stored in the tracks. What a pity as I then have to recolor all the tracks I am importing.

Thanks - Dr Tolle

Hi,

Could you attach a screenshot of the Import Options dialog, please?

please request this in feature requests and put in issues

As a workaround Import Track from Project does retain the Track Color. So you could create a Project that includes all the Tracks you might Import and get them from there instead.

Sure here we go :wink:

Sounds interesting. when I have created the project with all the tracks included,how can I then import the tracks from that project ?

Tried to look in YouTube for videos regarding this but couldn’t find anything

Best Dr Tolle

Hi,

File > Import > Tracks from Project…

Hi,

I have just tested it and it works to me. Import Tracks from Project and Import Track Archive, both are loading the tracks colors when I choose the New Track destination in the Import Options dialog.

Import tracks from project. - I have never stumbled upon that feature, but what a cool feature. I am definitely gonna use that in the future. Thanks !

Martin you say you tested it and it keep the colors. I have made a video so you can see how I do it, and maybe you spot how we do it differently.

https://www.dropbox.com/sh/hqg5fuk78ol1gbk/AACPlx5pGomE-IVM6f9xgXk1a?dl=0

Dr Tolle :slight_smile:

Preferences > Event Display > Tracks > Auto Track Color Mode
Try to change this to “Use Track’s Default Color” or “Use Last Applied Color”.

Hi,

There were some differences in our steps (I was using Audio tracks, I didn’t have an audio track above, I didn’t use the same color for all tracks). But now I tried to reproduce it exactly the same ways you did on the video. I’m sorry, it just works to me here.

Could you share your exported XML file to see if it’s on the Export or Import side? I would try to import it here on my side.

Could you try in Cubase Safe Start Mode?

I solved the problem now thanks to your guys help

I tried to play around with settings that you Accel0001 mentioned.

It turned out that - ‘Use tracks default color’ has to be chosen when importing tracks. This will keep the colors.
I had set mine to : ‘use previous track color+1’ as its appropriate for when adding new tracks I think.
So now I just need to switch between these 2 settings when importing tracks.

Thanks again to Martin and Accel0001

Best Dr Tolle

Hi,

Thank you for the information. It means that the import just follows the preferences settings. Which is good at the end.

You can assign a Key Command to toggle through the options - Preferences, Tracks, Auto-Track Color Mode

Thats already done, but thanks anyway :wink: