Imported audio becomes hi-pitched

Hi guys,

Just installed cubase 8.5 on my macbook pro OSX and for some reason when I import audio files into the arrangement editor, they become pitched up loads and sped up also.

Any reason for this and if so how do i prevent this?

Thanks in advance


probably a sample rate mismatch

Thanks DLearyUS

Yeah seems it - just all my samples import fine when i use a different system so it’s not the sample itself that’s causing this. How do i go about changing a sample rate setting or something to stop this from happening?

Set the project sample rate in Project Setup.

Set the preference Editing/Audio/On Import to convert or to ask you if you want to convert.

Thanks Grim - all sorted now!