Imported audio is out of sync with bpm

When I import songs into Nuendo 7 from another project that were completely in sync to the grid in the previous… they no longer are in sync with Nuendo?
Is there a certain way that I’m supposed to import them that keeps them synced to the fact same bpm?
It’s almost as if the wave form has added time in the front or something?

From where? Another program? How are you doing the import?

From both protools and studio one sessions. All the audio files are edited to start at the beginning of the session so there should be no issue in start times with the same bpm.
I then go to import files and choose the appropriate audio files downloaded and import them at the start of the session.

Perhaps verify the sample rate. Is the sample rate of the Nuendo project the same as that of the imported files?

And could be related to Musical mode. Check that Musical mode is switched off for all the imported audio and that linear mode is chosen for the tracks.

The sample rate is the same.
How do I turn off musical mode for imports?

I think you should try to re-import the exported files to their respective original DAWs. So the export from Pro Tools you import back into Pro Tools and try to line it up there. Same with Studio1.

Then see if you have the same issue.

Audio / Find Selected in Pool
Look at the musical column.

But this may not be the problem at all. Without a precise and detailed step-by-step account of exactly what you are doing and how you are doing it, it will be difficult to advise. The basic import procedure is as follows:

File / New Project
Project / Project Setup (set the sample rate to the same sample rate of the audio files you are about to import)
File / Import / Audio File (select the audio files)
In the Import Options dialogue select your preferences for the import
In the Insert objects… dialogue select ‘Different Tracks’

Result: the audio files are imported onto different tracks at the current locator position and are lined up perfectly in the audio sense. This has no relationship with the current bpm.

If you are expecting the import process to somehow know what the bpm was in your pro tools session then no, with the above procedure, Nuendo will not know the bpm. You’d have to deal with that separately. Take a look in the manual for further clarification.