Imported MIDI tracks reverting to "Acoustic Piano" on load

Hi guys, I’m hoping someone can clear up this small but frustrating problem I can’t seem to solve. I’ve imported two MIDI tracks from Guitar Pro 6 into Cubase 7. I routed both tracks to Halionsonic SE and it set the default program for both to “Acoustic Grand Piano”. Every time I would play the MIDI track from the beginning it would change the program setting back to the Grand Piano. I figured out how to fix this by going to the MIDI List Editor and erasing the “Program Change” tag at the beginning of each track. After that I edited each track to my liking in Halionsonic, saved my project and exited.

The next time I loaded my project I noticed Halionsonic/Cubase had reset both tracks back to the Acoustic Grand Piano setting and all of my program settings were gone. To remedy this I recreated my custom settings for each track and then set them as a custom track preset. I thought this would fix the problem but it hasn’t gone away. Every time I load my project each MIDI track still plays as an Acoustic Grand Piano until I load my track preset. The Grand Piano program preset is selected on the left side of the screen where all the track shortcuts are, but I can’t find a way to change that. Is this what’s causing my program’s to reset every time I load the project?

Does anyone know how to fix this? Or is my only option to get the sound I want out of Halionsonic and the bounce to audio?

Open List Editor, delete first prog. change. Look to MIDI import settings for future imports.

Wish I had a nickel… .

I’ve already done that though. I only have notes in both MIDI tracks when I check the List Editor.

Screenshot of LE?

http://i.imgur.com/whqc6QU.png

http://i.imgur.com/aXixuGH.png

If you need more screen space I can upload, but that’s the beginning of each track in the LE.

There must be a PC in there somewhere, scroll down the LE and make sure. Is there a master track that also gets imported?

I’ve triple checked, there is no program change in either, all notes. There no master track I’m aware of either, there’s only two MIDI tracks.

Can you PM me one of the MIDI tracks so I can try to see what’s up?

Sure, give me a sec

The track you sent was drums. Is the MIDI track set to channel 10?

I sent you a PM, I must’ve exported the wrong track. Will fix tonight.

Update:

I exported the MIDIs I had into a new project and played them. It kept all of my settings intact and sounded fine. I then re-imported the same file to the original song to see if I could replicate this with a new instance of Halion Sonic, but I couldn’t. The programs still reverted back to Acoustic Piano when the project was closed and reloaded. I’m wondering if this is a bug with Halion Sonic SE.

The acoustic piano is the default load instrument in all sixteen slots of halion sonic. If that’s the case, you would have to put a program change to select the right instrument’s into the start of your tracks,(especially on generic midi files) preferably into an eight bar count in to give them time to load into ram or/and start disk streaming…?

Though if you’ve saved the project with selected instruments they should just load as a matter of course