importing audio wrong speed

been importing audio files to cubase and they are not the same speed as they play back in finder
the audio i’m importing is 44kh 10 seconds long, i have tried the dialog box option of converting to 48khz and also setting up anew project that is 44
but every time i import it the audio clip is reduced to 3 seconds long
i can import it into audacity and it plays back at the correct length
any ideas please?

i’m using a mac

UPDATE: turns out it was a little box called musical mode, that is automatically in on in cubase 9.5 that foxed me, its not default on in 8.5