Importing Flow - doesn't show up in score

My aim here is to produce a collection / booklet.
Several pieces which are all separate Dorico projects.

I had hoped that if I used the import flows function I would be able to begin stitching this together but I have fallen at the first hurdle
I have imported a flow from a second project, and the Flow information in setup is there, but it doesn’t show up on the score editor / piano roll whatever you’d call it… Unless I choose Galley view in one of the Full score tabs.

Is there an easy guide to how these things go together?
Or would it be easier to do all this by editing the pdf output?

Typically if a flow shows up in galley view it will also show up in page view.

If you switch to Engrave mode, you’ll see (on any page) that the blue music frame has dropdowns in the top left corner. The second and third dropdowns should both be set to “All” (and the first dropdown should be MA or something else beginning with the letter M).
Is that the case, here, or is the Flows dropdown set to an explicit list of flows?

Sorry, I’ve been staring all over this screen in Engrave mode - but can’t figure out what a ‘blue frame’ might refer to.
I can see a ‘pages’ dropdown (on the right though) and ‘Master pages’ and ‘Flow Headings’ but there are no dropdowns on the left hand side of the screen just the formatting frames sections…

No, at the top of the page itself. Specifically, the text frames are outlined in green and the music frames are outlined in blue.

Apologies - you need to be in the Frames tool (or the Master Pages Editor) in order to see the dropdowns.

I don’t see this - the same area of mine looks like this
what am I missing?
blue frame

See my edit above: you need to turn on the Frames tool.

OK thanks I see - I closed everything and started over again.
Still getting the same though… Now this corner looks like this…
But there is not option within those dropdowns to select anything other that that which can be seem.
There is no option to select ALL
top left

Yep, now we’ve ascertained that’s the problem, you need to double click either of the master pages to fire up the master page editor. I think you should find an All setting in the same dropdown within the master page editor. If not, try unticking all the individual flows that are ticked on that list and that should reset it, if memory serves me correctly.

Thanks I’ve found that, and finally I can see the second Flow appear in page view!. Phew.

But all the title info and even the Footer copyright year has changed.[ie; it’s now the same on every single page]
I am assuming this is because there is one Master page shared between all the flows that might be included.

Is there a way of breaking that chain, so that it all looks like the individual projects originally did?

Back in the master page editor, have a look at the text tokens that are used at the tops and bottoms of the pages (both the first and default master pages, and there are separate ones for part layouts, by default).

I suspect they’re currently {@projectwhatever@} . If you replace them with {@flowwhatever@} they will reference the Project Info fields that relate to each flow.

You may need to re-enter some of that information in Project Info, given that the original projects may have had this information stored in the Project fields rather than the Flow fields.