Importing midi drums with tuplets

Hello,
When importing a midi file (channel 10) containing triplets, Dorico shows this:


The music is correct but Dorico makes it very complex by creating these several voices and overlapping triplets.
Is there any way to force Dorico to import on a singular voice? Or to merge and simplify this notation?
I have selected “Use single voice” and “Truncate to Shortest Duration” for Percussion in the Notation Options.

I am having a really hard time trying to move and merge voices, split and merge triplets… I’d appreciate some help!
I’m attaching the midi file in case.
thanks
Florent
Test3.mid.zip (840 Bytes)

I do wonder whether 4/4 is the most natural time signature for this music, but perhaps the drummer is playing something across something that’s straighter in the other parts?

Anyway, if you go to Edit Percussion Kit via the Players panel and set all of the instruments in the kit to use the same up-stem voice, you should find the results are a bit cleaner to start with.

thanks Daniel

Yes, this is a long piece in 4/4 and in this section the drummer plays with a triplet feel.
Since I could not figure out how to write a polymeter with 4/4 and 12/8 in which a quarter note equals a dotted quarter (following the tricks here https://www.scoringnotes.com/tutorials/masking-meters-creating-polymeters-metric-modulations-dorico/), I’ve decided to keep everything in 4/4.

All stems up helps getting of one voice, but it still looks pretty messy with these two voices.


Any idea on how I could make it look like a drums part without only one voice without having to re-write everything?
thanks!
Florent

Go into Setup mode and edit the Percussion Kit. For each instrument, there’s a default voice and stem direction. Work out which instruments you want, and which stem directions, then set accordingly.

thanks, this is exactly what Daniel was recommending but it still creates multiple voices and weird nested triplets

The fact that your screenshot shows one blue voice and one red voice proves that you’ve got two different voices going on. Having done what Daniel suggested, try selecting the whole passage, right-clicking and going to the Percussion submenu. I believe there’s an option there along the lines of “Reset Destination Voice” - sorry, this is from memory - try clicking it.

Thanks, but this is still not working.

In the Notation Options “Use Single Voice” is selected
In the Setup / Edit Percussion Kit, all notes have stems up
When I select everything and click on Edit / Percussion / Change Voice / Reset Destination Voice, this does not really do anything
I am able to remove a few rests by selecting some notes and Edit / Percussion / Change Voice / Extra-up stem Voice, but it still is unreadable.


Also, I cannot figure out how to split these large triplets, nor how to combine the other triplets.
thanks for your help!
Florent

Have you tried creating a working layout for the drums where you show each kit member of a separate line (rather than a five-live staff) just to clarify what you have where? That may clarify what you need to do to proceed.

thanks, I basically only have kick, snare and hi-hat

OK I am going to re-write everything by hand, it’s been 2 days that I’m trying to make this work and it does not work.
I wish Dorico had more/better options for importing mid files… this is frustrating

So there is apparently a bug with percussion and triplets https://www.steinberg.net/forums/viewtopic.php?f=246&t=162861&p=872013#p872013
I can’t even write this part by hand…

Could someone help me? I am willing to pay money for the person who’s gonna be able to import this midi file and make it look like a real drum set part.
Test3.mid.zip (840 Bytes)

Here you go. I entered the drum part again based on what I thought the rhythms were from listening to it. Hopefully this is close to what you’re after.
Test3.dorico.zip (472 KB)

thanks so much Daniel

I am basically only using Dorico with midi imported material so re-writing everything after it’s being imported is really a problem for me. I wish the midi import window had more options.
thanks
Florent