Importing Superior Drummer 3 MIDI Into Dorico?

Hi all!

I’ve been enjoying working in Dorico 3 Pro, minus a couple little things which I will detail sometime next week (in a separate post). Right now I would like to Import my Superior Drummer 3 MIDI Loops into Dorico and I haven’t been able to do this successfully 100% yet. There are always some parts of the kit that either don’t appear at all, or aren’t playing the correct drum, and that obviously makes it a PITA to work with. At least it handles this better than Finale…lol.

Anyway, in Studio One v4.5, I open a project which has the drum loop I want to Import into Dorico. I proceed to open the PRV and set it to the Drum Editor. There I select the General MIDI map and drag the notes to the corresponding parts of the kit according to this map. Once I’m done, I Export a MIDI file of the Project and Import that into Dorico. In Dorico I have Superior Drummer 3 inserted as a VSTi loaded with the same exact kit and with the General MIDI Percussion Map. You would think everything should translate perfectly, but it doesn’t. Or am I doing it wrong? What am I missing?

Hope you guys can help. Thanks!!

I’ve had problems importing EZDrummer loops into Dorico because they’re not strictly GM. There are about 5-10 different hi-hat strokes for instance, all on different notes, so when you import into Dorico it has no idea what they actually correspond to. I think I was able to import more successfully if I added the extra EZDrummer pitches into a percussion map and then drag and drop a loop into the drum instrument in Play Mode.

Paul: I was very close to getting this working with EZ Drummer, but today (even after rebooting my computer), Dorico will not Import the “EZ Jazz.doricolib” Percussion map into a newly created project. I setup a Drum Kit (Full), add EZ Drummer as a VST and try to Import the map and it won’t do it. It is still there on the hard drive. Bummer, because now I’ll have to add ALL of the mapping over again and export a new file. Any idea what went wrong? I don’t want to waste time creating another map just to lose it again. Here is the library file “EZ Jazz.doricolib”

Thanks in advance.
Dorico Percussion (6.49 KB)

I was able to open an older project and I found the map with a different name and I exported it and then imported it and it worked. I’m not sure what happened with that file though. Probably my own fault somehow.

Ok, glad you got it sorted.

Back to the original question and help for Jose7822:

Use the Percussion Instrument Playing Techniques dialog to add additional noteheads and playing techniques. For example if your Superior Drum patch has 6 ride cymbals, map add them here using any symbols you want and the playing techniques are as written next to the noteheads (but you can also change them):

Note that the name of the “Instrument” field in the Percussion Map will be the name of this staff line, in this case "Ride Cymbal (Low). If it is anything else, this won’t work.

Once mapped like this the 6 various Ride Cymbals show up on the staff with the variety of chosen symbols and if you assigned the MIDI note #'s correctly in the Percussion map, they play back perfectly.

Do this across all of the various instruments in the kit (Bass Drum, Toms, Crash, Hats etc.) for all of the items/strokes/sounds in Superior or EZ Drummer and you can then drag and drop those great MIDI grooves from EZ or Superior directly into the grid in Play Mode and they not only play perfectly but they notate perfectly as well.

Hope this helps, as I’ve made a career out getting this to work.

One issue is how are the various lines named in Play Mode? For example, even though we are using Ride Cymbal (Low) in this example, my line in Play Mode simple says “Ride Cymbal”. I can’t figure out where those names come from and how.

1 Like

Screen Shot 2019-09-20 at 11.31.53 AM.png
This picture shows the 6 different Ride Cymbals ALL showing up in the Grid in Play Mode as a “Ride Cymbal”. Of course they are 6 different strokes of the cymbal as can be seen in Write Mode but not here. Once again, not sure where the name “Ride Cymbal” in Play mode comes from or is populate. Perhaps Paul might know?

Now to do this for all of my EZ Drum Kits for all strokes . . . . . . . . . . . I’ll report back in two years when I’m finished. Seriously we should create and share these.

Man, I was trying to save some time by doing the opposite (creating a simpler Drum Map version by lumping together all of the Hi-Hats, etc into the same MIDI note in Studio One), but Dorico didn’t recognize some of the notes. I guess I have no choice but to create a full fledged SD3 Map in Dorico instead.

Thanks guys! I’ll give this a shot this weekend. And YES! Totally agree about sharing these cause they are time consuming indeed!

Here’s a percussion map that I’ve used with EZDrummer that you can use as a starting point. It has mappings for the extra hi-hats. If you import the doricolib from the Percussion Map editor and assign it in the Endpoint Setup dialog then you should be able to drag and drop from EZDrummer. I expect that this should work with Superior Drummer too.
ez (2.06 KB)


I haven’t been able to create the drum map yet, so this might come in handy. Thanks so much!

Are you willing to share the SD3 percussion map?

Yes, but it will take me a while to get to creating it since I’m currently working on transferring a bunch of Finale arrangements into Dorico.

It might be some time next week.

1 Like

Awesome thank you!

OK, I’ve created the MIDI Map for SD3, but now I need to create the Playing Techniques. I’ve just been so busy importing Finale charts into Dorico that I haven’t really had time to tackle this, but I will (and then I’ll share it here once I finish testing it).

Just wanted to give you guys an update :slight_smile:.

Hi guys!

I’m having some problems with the Drum Kit I created. For one I’m unable to Import it into other projects. Been following these steps, as described in the manual:

The Drum Kit doesn’t populate in the newly created Player Card. The Player Card remains empty after I press Import Kit and select the Doricolib that was created when I exported the kit. What am I missing?

BTW, this is the same exact issue that is described by tcreverb in a previous post, above.

This is a bug in Dorico 3.0, I’m afraid, but it will be fixed in the forthcoming minor update, which is expected this week.


That’s awesome news :slight_smile:.

I’ve also been experiencing a LOT of hangs (program not responding messages on Windows) in Dorico, which are usually playback related since they mostly happen after I press PLAY. They require forcefully closing Dorico. Hopefully this is something included as a fix in the upcoming update.


There are a few known issues in this area (which mostly should be much improved in the update), but the first thing to check is to go to Edit > Device Setup and re-select your soundcard and sample rate. If your system has defaulted to 48k then you run into this.

My system has defaulted to 48KHz, I see. Do I have to do this every time I turn on my computer (at least until the update is released)?


No, it should be remembered