Importing WAV files into Cubase causes them to sound strange with a little delay effect

I’ve downloaded drum samples and they’re WAV files. When I import the samples using the File Browser or simply dragging and dropping, they sound as if there’s a little delay effect on the samples. There is no delay effect, it’s more like the sound is being played twice in quick succession, almost as if it’s glitching, it also sounds like when someone speaks into a spinning fan and your voice starts sounding wavy and strange.

This happens with every file I import, FLAC and WAV. Bit depth and sample rate are all matching, I’ve converted the files to mono and that doesn’t work either. Tempo is also not the problem.

Hi,

Is the Audio Event in the Musical Mode? Do you stretch it significantly? Try to switch the Musical Mode off, please.

Could you try to increase your Audio Device’s Butter Size, please?

Isn’t it okay back from the MediaBay too? Can you observe the same if you close MediaBay?

Could it be you hear the signal twice - through Direct Monitoring and through Cubase?

I’ve tried all of these and nothing works, also, what exactly did you need me to do in the MediaBay?

Enabling Monitoring disables any audio, I’ve also enabled and disabled direct monitoring but that does not make a difference.

Hi,

What do you mean? By enabling Monitor button on the track, you switch to don’t play the signal is the track back and play the signal from the input back.

Anyways, I’ve tried all these options and nothing seems to be working.