Improper display of Time-Stretched Files


Currently running Cubase 9.5.10 build 79 On Win 7Pro 64bit

If I perform a time stretch on a long file (let’s say an hour for argument’s sake) the resulting waveform on the screen does not match the audio. It is off by a few seconds. If I bounce this file, and then drag the bounced file back into the editor, it is perfect. Something is wrong with the way the initial file is being drawn.
I am using the Audio>Processes>Time Stretch function and using the elastique Pro - Tape algorithm with the Time Stretch Ratio set to 200%

The fact that the resulting waveform doesn’t match up makes performing further edits impossible until the file is bounced, and re-imported, which is an unacceptable work-around on a regular basis. I perform the same tasks in my old version of Nuendo 5 flawlessly as well as in Cubase 8.5 so ideally, our workstations running 9.5 should be able to achieve the same result.

Thanks in advance for any ideas.

I’ve run into this as well, on short files. There’s definitely something super glitchy with audio editing in general in 9.5. I have found that even if I undo back to my original file, it is corrupted.

Cubase Pro 9.5.1
iMac 27" Late 2015 OS 10.11.6
32 gb ram
UA Apollo Thunderbolt Interface

Can we expect any sort of fix for this issue from Steinberg?

Is my only option to use an old version of CUbase for the time being until this is resolved? Because it is a function I use very frequently…

Do I need to look to different software moving forward? My facility has 8 audio workstations that I am responsible for…all run steinberg products, but if this is what I can expect I’d rather sadly have to look elsewhere after having been a Steinberg guy for about 15 years…

Hello? Steinberg?? Ii’m struggling here…can I perhaps get keys for the 2 systems that are running this software so that I can downgrade to 8.5? 9.5 is un-usable i this state for us.

Your license can run any previous version of Cubase, just install.
DOP will get fixed at some point, but it is unlikely to happen fast, better install C9.0.30 that does not use DOP.


I too have been having Time Stretch issues since the 9.5 upgrade. Sometimes the amount of time stretch applied to a slice attaches itself to the next section of the track, pushing everything past the edit to the right. It also likes to overlay the short stretched section on top of the original full-length recording, even though the original also gets stretched. As was said previously, the audio editing in general seems really off.