Improvement request for Arpache 5/SX - for live play or tracking

I’ve done a search but can’t seem to find this reported so here goes…

As it stands Arpache has a major flaw (IMO) when you try to use it live or when tracking.

To demonstrate this:

  • Set tempo to something slow so you can hear the individual notes (40bpm)
  • Loop 2 bars on a track with a piano (or similar)
  • Record or draw in a simple triad (C-E-G)
  • Quantize the EXACT first beat of the bar and set the length to 1 bar
  • Add Arpache 5 as a midi insert on that channel and just leave it on the default preset but bring the range down to 11 so you don’t get the ‘octaves’ triggered.
  • You get an arpeggio as expected (C > E > G > E > C - C > E > G > E > C) (why does it double the first note the chord when looped - annoying but fixable in the ‘user’ section)
  • move the ‘E’ and the ‘G’ ONE tick later in grid edit.

you will see that you get an extra ‘C’ note on the beginning of the arpeggio

Try something similar with a real arpeggiator built into a softsynth or in hardware - you don’t get that extra note - it works much better and is much more musical.

This means it’s impossible to trigger correctly live or whilst tracking as it’s impossible to hit a chord at EXACTLY the same time…in fact the MIDI protocol won’t actually allow it. You will aways get that double note at the beginning depend on which note reaches Cubase first.

I don’t think this is a ‘bug’ as such, but Steinberg have redefined what an arpeggiator is by making it not as useful or as musical ?

I think we can see ‘why’ it’s doing this (because the logic is wrong :slight_smile: ) be great to get a ‘fix’

FWIW - Arpache is retriggering a new arpeggio every time a note is changed - this is wrong and when you attempt to do more complex ‘evolving’ arpeggios it falls apart altogether and you’re likelty to just get a single repeated note :smiley:

Does that make sense ? or have I missed something really obvious.

1 Like

here’s an extreme example of the problem with Arpache.

note: it’s LOUD - so careful with volume levels - and don’t judge my performance :slight_smile: , this is just me pressing keys to show the problem.

This is the same 2 bar midi loop . 1st time with the UHE pro1 built in arpeggiator and 2nd time with Arpache (single repeating note :slight_smile: ). Both are set to the same ‘up’ settings. It shows how badly implemented the algorithm is…Arpache produces just the ‘root’ note because it restarts the arpeggio on ANY keypress. It should only be set to restart the arpeggio when no notes are playing.