In-App purchases and Roomworks SE registration

If you register you can get a free Roomworks SE effect. But I have to do this every time I open Cubasis because it doesn’t remember the registration. Is it the same with the in-app purchases? Will I need to restore the purchases each time I run the app?

Hi misohoza,

Thank you for your message.

Our quality assurance gave your issue a short check.

Unfortunately, we are unable to reproduce the problem.
Once RoomWorks SE has been unlocked via registration,it remains in this state.

Please let us have more details.

Best wishes,
Lars

Hi Lars,

Thanks for looking at it. Here’s a short video showing the problem:
https://youtu.be/42_rDmxd9Hs

If the project already used the Roomworks effect then it loads and looks like it is active. But when I want to edit it asks me to register. Sometimes I need to fill in the details again and sometimes not. Like in the case of the video.

Hello. I have the same problem with Roomworks. I open Cubasis, register Roomworks. If I close and reopen Cubasis I have to register it again.

Hello, I started with the same problem yesterday. I had to register few times, then it stayed tuned
Overnight some mystery happened, today it seems to be okay. Roomworks is still registered when opening Cubasis :slight_smile:))
So give it some time, may solve the problem (even this nice app has to sleep sometimes ??? :wink:

Best wishes

Hi PeMu64,

So, the issue does not appear for you anymore?
What about the other users in this topic?

Thanks
Lars

I still have the problem that I have to register it again and again. Cubasis 3.1.1 is installed

My Phone is the Samsung Galaxy S9+ with Android 10

I bought one of the add on packs (Classic Machines) and since then it seems to work. It remembers both the purchased pack and the Roomworks SE registration. So I don’t need to register it again each time I run the app.

Hi Lars,

that´s right, no problem since then.
Later i bought the Micrologue ARP Add-on, also no problems until now :smiley:

So - the only thing that last´s, is the crackling problem on my S10 as other users reported, too. Hope you can fix it.
Like other users, i also experienced no disturbance with my BT_Headset, but that constellation produces too much latency for me, so i have to find some other solution - or wait for your´s :wink:

Best wishes

Hi all,

Our engineering gave the issue another check, where things worked as expected unchanged.

If some of you still encounter the issue, it might help to clear the Google Play cache, followed by re-purchasing the IAP’s:
https://www.androidjungles.com/clear-google-play-store-cache-data/

Best wishes,
Lars