In Key Commands, how to move notes right/left?

Hi there, I’m trying to customize some key commands, specifically I’d like to:

  • Move notes left & right using the arrows, with a single arrow stroke (instead of Alt+arrow: Alt-left, Alt+right). I’m not able to find where to change this key command

  • Move the cursor using Alt+cmd+left & alt+cmd+right (instead of the default left-right arrow movement). Sometimes it says to me something like it will overwrite EventEdit.MovebyGrid, but I can’t find that key command


Al, you’d need to edit these shortcuts by hand in your keycommands_en.json file in a text editor. You’ll find this file in /Users/your-username/Library/Application Support/Steinberg/Dorico on Mac, and in %APPDATA%\Steinberg\Dorico on Windows. Use a proper text editor (like Sublime Text, BBEdit, SciTE, etc.), not TextEdit or WordPad.

If you search through the file for “Alt+left” and “Alt+right” you’ll find the various commands you’re looking for: you’ll also need to find the commands that already have the shortcuts “Right” and “Left” and change those too, otherwise the shortcuts will collide and quite probably none of them will work.

Once you’ve finished editing the file, I suggest you copy and paste it into this site to make sure it’s still valid: Dorico won’t load an invalid JSON file and you’ll end up with no shortcuts at all.

You’ll need to save your shortcut file, then restart Dorico to see any changes.

Thanks, it worked perfectly. I use vim editor so no problem :slight_smile:

Also, I found something strange, (I did a backup before touching anything, so no problem anyway); the following keywords disappeared somehow:
“EventEdit.NavigateLeft” : [ “Left” ]
“EventEdit.NavigateRight” : [ “Right” ]

I’m pretty sure that I didn’t removed those lines, but I’m unable to reproduce the error. If I reset the key commands (so the keycommands_es.json file dissapear), and then modify some of them (to get again that file), those keywords are there again. As that keywords are not present in the GUI key commands, it may be related to that, and it probably happened because a mixture of me modifying the key commands. I’m sorry for not being able to provide more information. (but it works now, so it doesn’t matter, I’m saying this just in case it may help to the dev team somehow).

Oh, just for the records, in case this may help to someone, I had to use the word “Ctrl” instead of “Cmd”. I mean, it seems that in my mac keyboard, the Cmd key is translated in that file into “Ctrl”. Probably this has something to do with PC/Mac compatibility