Inconsistent space in messa di voce objects

I’m working on a project with a lot of dynamics, including tons of <>, and I have noticed some strange behavior where some of the messa di voce objects have different amounts of space in them. I finally found a seemingly-perfect example.


This was copied from my existing project into a new project with essentially default settings (at least, whatever I have saved as default) — right now the gap between adjacent hairpins is set to 1 space, and gap between messa di voce hairpins set to 1/3 spaces. If I increase the messa di voce hairpin to 1 space, all the gaps get bigger. These hairpins are not linked vertically. If you delete the 4/4 time signature, suddenly they all look fine. Adding a third cello (so, a staff underneath the currently-lowest staff) also fixes this.

Deleting the piano dynamic doesn’t change anything; changing barline interaction to “stop before” doesn’t change anything.

Minimal Dorico project attached. If Daniel doesn’t have a magical solution for this, I’ll have to delete these problematic <> and replace them with “< >” so that I can at least manually make them look okay. It’s frustrating that messa di voce objects are so… unadjustable, but I understand why that is.

Thanks.
MessaDiVoce.dorico.zip (539 KB)

I found a “workaround” of sorts: if I select the objects on the upper staves and manually change their Barline Interaction to “Stop Before” the space between them is correct. BUT they then look obviously uneven, which is the whole point of using a messa di voce… (I added more music to show the unevenness.)

Seems like there’s something unideal here with the Barline Interaction property, and also the calculation of where the visual center of the messa di voce is.


MessaDiVoce-Uneven.dorico.zip (543 KB)

Dear Jeffrey,
I think the usual workaround — at least the one I’ve been using on some music that used the <> a lot — is to change an unused accent glyph (stressed or unstressed, for example) by a custom <> glyph in Engrave mode > Engrave menu > Music symbols editor.
The obvious problem is you can no longer edit any length of this new “accent” and of course, it will not playback. But at least it will consistently show where you need it to be!

I think I’m probably being a bit thick, Jeffrey, but can you clarify for me what you want the appearance to be? Do you want the gap between the messa di voce hairpins to be 1/3 space on all staves, regardless of whether or not they are interrupted by a barline, or something else?

Hi Daniel, thanks for the writing. I would think that the gap should be 1/3 spaces for this file—my expected behavior would be the gap is whatever the “Gap between messa di voce hairpins” is set to, with the gap centered on the center point of the note in question, without regard to barlines or other interruptions. (I would also expect the symbol always appears symmetrical even when a dynamic begins or ends the symbol—as I understand it, the whole idea of a messa di voce is that it is visually symmetrical.)

So in this screenshot, I would think all the messa di voce symbols should have 1/3 of a space between them, and be symmetrical. It appears like in the “extra wide” ones, they have twice that much space. But if I set the barline property to “stop before” then they are lopsided.

Apologies for not being clearer—does this make sense?


(Thanks Marc, but unfortunately that really isn’t the right result for me in this piece, it’s way too small in many circumstances.)
ManyMessaDiVoce.dorico.zip (542 KB)

No problem, Jeffrey. I’d like to see some improvements in messa di voce markings too, so I am following this conversation, silently from now on. :wink:

Thanks for the clarification. I thought that was what you were asking, but wanted to make sure. I’ve dug into this somewhat tonight and I can see what’s happening; Dorico is incorrectly applying a gap before the barline to the first segment of the messa di voce, and then applies the gap defined in Engraving Options on top of that. We’ll look into this and see if we can fix it.