Inconsistent stem lengths

I seem to be unable to find settings which produce consistent and attractive stem lengths in all conditions. In the example below, why does Dorico lengthen the stems between the first and second beats? If I select the first beat of 16ths and shift all the notes up a step, the stems lengthen instead of becoming shorter. Why? If I shift the last three 16ths up a step, the stems suddenly become much shorter. Again, why? I’m finding that I have to adjust these by hand and, since propagating properties doesn’t seem to work, I have to do it in both score and parts. What am I missing?


stem lengths.png

If I had to guess, I’d say that rules for avoiding incorrect beam placement within the staff are being applied (unnecessarily) to the beams outside the staff, which they shouldn’t be.

If I am correct, I would imagine that somewhere down the Dorico Roadmap this would be addressed, but I could be wrong.

FWIW, here’s what I get by default:

If I open the DORICOverture file that ships with Dorico and enter that pattern I get this:

Not sure how these settings differ from yours Vaughan, but there clearly are some different beaming options at play here. It looks like there’s some setting you can change that will avoid that odd lengthening on beat 2.

Vaughan, you’d need to share a project that exhibits this behaviour.

Todd, the DoricOverture was constructed in a pre-v1 beta (or possibly alpha) release and hasn’t been updated since - there are all sorts of weird things with that file!

LOL! Didn’t realize it was that old! I honestly just sorta picked it at random to see what the beaming settings were in a shipping file. Neither my file (with lots of customization) nor that demo file show the same sort of extension on beat 2 that Vaughan’s shows, so there must be some setting he can change to avoid doing it manually.

Yup. Tommy wrote it for (and was interviewed at) the Dorico launch in London, before v1 dropped in October 2016. That launch event was recorded and streamed, and is still available here.

I’m having a similar (the same, I think) problem. Generally It is as if stems in many situations get extended too much, and especially when it comes to 32nd beams as shown in the example.

In the first bar, I have the same problem: stems getting too long when the same figure is transposed a 2nd.

In the second bar I have dragged the beam manually to the position I think it should be (seen in numerous published scores…).

I’ve been experimenting now for ages with different settings, but I just can’t get it to work. I’ve also tried to open a completely new project, but it’s the same problem. Am I completely missing something…?

I’m not sure how my settings differ from yours, but here’s what I get by default:
dorico

There was a discussion of 32nd note beaming issues last spring in this thread.

Ideally I’d like to see a quarter space slant as you have it, but with a slightly widened beam gap to avoid that wedge on the bottom. Something like this, which as far as I know there still isn’t a way to do in Dorico.
Finale

Yes, it looks really great with the widened beam gap in your example!

But I still think the main problem is that the stems for some reason seems to be too long - as if it’s jumping a space too much. I hope it’s possible to change this (with a “maximum stem length for beamed 32nd’s etc.” or so…). I feel like it’s such a basic thing, that I must simply just be missing where to click… otherwise I’ll click and drag (all of them)…

I’ll need to confer with my colleague James, who is responsible for all of the beam slant and beam snapping algorithms, when we’re both back at work in the New Year.

I suspect that what’s ending up happening here is that the requirements to produce a quarter-space slant, avoid beam corners, and ensure the correct minimum distance between the innermost beam and the notehead are in conflict. Certainly in Todd’s image from Finale, the stem of the first note in the beamed pair is too short, as far as Dorico’s concerned.

We have done a load of work in this area, about a year ago, which was included in Dorico 3.1, but determining slants and snapping for demisemiquaver (32nd note) beams is a pretty vexed one, so obviously we still have some distance to travel.

Slants, gaps, snap positions, especially for 32nds is quite tricky, I know… Yes, maybe there’s a conflict somewhere, that would make sense. Anyway, it would be nice to have the option to set the min/max distance between beams and noteheads or length of stems, or something like that. For now I’ll just do it manually.
(by the way, I just switched to Dorico after many years in Finale and then Sibelius, and I’m really impressed!!)

What about adding a Beam Gap setting to Properties/Beaming? Instead of just having Engraving Options/Widen or Normal for 32nds (which I think only widens by a fixed amount), have a user customizable setting where the user could increase the gap in 1/8 space increments. Obviously having settings to automatically achieve the desired look would be better, but this way a user could at least manually get the look they were going for.

Yes, we do plan to add properties to control beam thickness and gap at some point in the future.

2 Likes