Incorrect display of trill notes

Hi — I am having a problem displaying trills correctly. Funnily enough they previously were displaying correctly in this project some months ago, but now are not. I have the settings set as shown in the screenshot, and yet the trill is still showing as an aux note instead of an accidental above the trill sign. There seems to be no settings in the properties of the trill to allow a manual override either.

Also, if I stick with the auxiliary note, how do I get it to show as E-flat instead of D-sharp? When I select it, I can’t use alt + to change it…


Have you tried changing the interval property in the lower panel?

Yes I’ve tied that…

It works for me if I set the interval to an augmented unison.