Incorrect dynamics when resuming playback

When I’m playing several times the same thing using “P” for restarting from a given position, the dynamics are not correctly rendered if I have chosen a note which is after the definition of the last dynamic.

In general you should find that dynamics are “chased” properly in playback, because Dorico builds up a profile of the dynamic level at the position of every note. Do you have a simple example you can share that would allow us to see this problem in action?

I have noticed that if I strike several times “shift+space” I can finally get the right dynamic…

If you can provide us with a reproducible case where it’s easy to make it go wrong, please do.

Autoportrait.dorico (1.4 MB)
In this work, if you play from bar 50, strings do not (always) play p as expected.

I wonder if this is not due to the tremolo articulation.

for what it’s worth, I have had quite a number of situations with the BBC Core where chasing has not worked correctly – generally in longer and more complex flows/projects. The problem is that there is no single clearly reproducible instance where it always happens – it will vary from take to take.

In your project, I cannot reproduce an issue at bar 50 despite numerous attempts (and don’t think a tremolo should in itself be the cause of the problem). Is this a complete work, as far as it goes? If not, and you have found the issue when auditioning the whole score, please post the whole score if possible as I’m convinced these issues are not readily reproducible when only trying out an extract.

Thanks for your interesting comment. No, this work is not finished, but I have the same problem in many others, often long ones, like you. This never happens when auditioning the final work, but when you are working and repeating many times the same thing : when the cursor goes to the desired place, the dynamics are not always the right ones. Another problem which I have very often with the dynamics is that the relevant CCs created by Dorico are not continuous : there are sudden volume changes that I have to manually modify.

it’s essential, I would say, with the BBC SO to completely disable dynamics beat stress options as well as the Humanize dynamic feature in Playback options, otherwise unpredictable dynamics can and will occur.

1 Like

Thanks a lot ! I didn’t know that… Where is the “beat stress option feature” ? (I do not even know what it is…)

Library menu -->Playback options → Dynamics. It’s fine to keep the increased dynamic for “accent” but otherwise I’d zero them. It may be a useful feature for certain libraries like the bundled Halion but it causes no end of problems with many 3rd party ones where small difference in dynamics can make large differences like the BBC.

Thanks David. Do you think I should do the same with Spitfire solo strings ?

probably – but I don’t use them so can’t say for sure.

Anyway, my question was stupid, as these settings are global :wink:

actually it’s not a stupid question because the settings are not necessarily global – you have the option of modifying them for each Expression Map individually if desired in the “Playback Options Overrides” section…

1 Like

Ok, I see…