Incorrect pedal playback behavior if using volta brackets

Since reporting this issue to Daniel personally (email and Twitter) doesn’t work (maybe he’s too busy), I am posting this issue here.
The demo project file (which could help the developer team duplicate this issue) won’t be posted here and is already attached to the mail I send to Daniel.

The issue is that the actual piano playback could behave out of the engraver’s expectation in cases of using volta brackets.
I have a YouTube video which could demonstrate how this issue looks like (pay attention to the VST interface of Pianoteq):
https://www.youtube.com/watch?v=PL2C-Uqq4tw

Update: PDF file disclosed in one of my replies below in this thread.

I’ll get back to you when I have time, ShikiSuen. Please be patient.

According to the file you generated and attached to your email reply, this issue is more serious than what I expected.
See my email which enumerates all errors I manually found from the file.

(Basically, in this piece, every pedal lift must be placed at the point when a chord changes to another.)

Shiki, at least on the file I’ve mocked up here (attached to this post in case anyone else wants to try it), pedalling works as expected if you’re using the default HALion VST, both in bars 21-24 (as at the start of your video) and in bars 14-16 (as at the end of your video).

The fact that HALion handles this all correctly would indicate to me that this is an expression map issue. I don’t know anything about Expression Maps for third-party VSTs, but, if I’m understanding you correctly, it seems like the expression map for Pianoteq is misinterpreting chord symbols/8va brackets/codas/whatever as pedal instructions.
pianoleo pedal test.dorico.zip (415 KB)

There is no “expression map for Pianoteq.” It works fine using the Dorico “default” map.

It plays back Leo’s example OK for me. I tried adding some repeats bars and a rit at the end to match the original problem, but everything still worked.

However you can reconfigure just about every MIDI command that Pianoteq responds to within Pianoteq itself, so just from the demo video there could be any number of “hidden” reasons why this doesn’t work correctly.

Also the video appears to be an overlay of two different screen grabs, and it doesn’t have any sound when I view it, so the Dorico and Pianoteq parts of the video could be out of sync as well.

I use Pianoteq a lot, so I would be pretty surprised if there was a fundamental problem like “pedalling doesn’t work” and I hadn’t noticed yet.

Note, by default Pianoteq listens to all MIDI channels, so if Shiki is trying to play a written part AND chords on the same instance of Pianoteq, that might well create chaos (just as it would on a real piano!) In that case the solution is run two copies of the Pianoteq VST and configure them to be selective about what MIDI channels they respond to.

The default playback configuration in the Mixer DOES send both chords and written notes to the same channel, but needing to change that is hardly a “bug” IMO.

Well as I said, Rob, I evidently know nothing about how third party plugins interact with Dorico, but I think what you’re saying is that this is a case of configuring Pianoteq correctly, rather than a Dorico bug.

Daniel used my confidential project file (as “File A”) to export to MIDI file, then import the MIDI file back to a new Dorico project (File B).
After thoroughly checking the file B I found that the pedals in the file B behaves differently: Some places have unwanted pedal breaks, and some places have lack of needed pedal breaks.

But have you tried it with anything other than Pianoteq?

If you can reproduce the problem with a non-confidential project and post it here, that would be much more useful than saying “it doesn’t work for me but I can’t tell you any more than that.” Presumably it doesn’t depend on the actual notes in the score - you could just put four quarter-notes on middle C in every bar and the pedalling still wouldn’t work.

Just saying “I think there is a serious problem but I won’t tell you any details about it” is no use to anyone.

Certainly. I tried a lot of VST with default settings. Also, on Daniel’s side he has no PianoTeq installed on his computer.
The project file I sent to Daniel uses HALion Sonic SE with its default piano and default expression map.
Stop asking me stupid questions like this again. There is a reason I put you on my ignore list in this forum.

I am not saying that. Daniel has the project file. This thread is just a periodical reminder.


Phuck it. I disclose these files. (Reason is that the formal score changed a lot with decision of not using volta brackets.)
Due to the limiation of the file size, I post the PDF here and you non-officials could reengrave it by yourselves.
Dorico Pedal Bug (Source File) Full score.pdf.zip (80.9 KB)

Posting a PDF is utterly pointless. I’ve already spent some time copying a few bars of your project and it doesn’t give me the problem you have.

There is something specific to your project file that’s causing the problem to present itself.

If you’re not prepared to post a cut-down snippet of the Dorico file that shows the problem, then I’m out of here.

I am out of my attachment quota in this forum, hence posting this on box.com:
https://app.box.com/s/8p7w58ka5i8r4k5eq5m0dw5n4r6e9vta

I believe the problem is that the pedal line notches are not unwound correctly according to the repeat structures. So after the the first playback onwards the notches will be at the wrong position. A possible workaround is to split up the pedal line at the boundaries, ie at the start of first volt, at the start of second volta and at the start of coda.

Thanks for the workaround. The problem is that this may make the pedal lift sounds longer than a pedal notch-lift.
I always use pedal notches since I use Sibelius.

P.S.: I assume that your reply above proves you Steinberg official developers’ awareness of this issue. Hope this could be fixed in the next 6 months.