Independent Track Loop loosing sound Bug?


I have struggles with independent track loop for some time. The thing is hard to reproduce from creating new empty project but rather I got issue along the way during work on the project. When bug appears I basically delete all channels and effects to get that one channel (retrologue) in order to target the issue. As soon you enable independent track loop and set range it looses the sound.

  1. Open
    Independent Track Loop Bug.cpr (239.3 KB)
  2. Enable Independent Track Loop in key editor, and set range on the midi part.
  3. Hit Space (playback)
  4. Result: No sound

Cubase 12.0.7
-Disable preferences, as well previous 12 versions wont fix the issue.

Cubase 11 everything works fine.

Can anyone confirm this please?

Anyone use independent track loop? :thinking:

It’s a bug from 12.0.50 and up… it happens when the selected channel has activated Read automatization. :slight_smile:

Indeed, in 12.0.40 Independent Track Loop works as expected.

Bug repro:

  1. Make new empty project
  2. Load VSTi (Retrologue for ex)
  3. Make midi part with few notes
  4. Activate Independent Track Loop and select range containing some of the notes
  5. Activate Read automation
  6. Result: NO SOUND!

Even if you turn off Independent track loop afterwards still got no sound.
Interesting that @GregOndo promote feature 5 months ago on version that is probably broken(I assume that he used up to date version in this video) Creating Beats with Independent Track Loop | Cubase Q&A with Greg Ondo - YouTube

All versions from 12.0.50 and onward has this bug.

How come that Steinberg mess some features in Maintenance update over and over?

1 Like

I can confirm this.
Although we must hit Play (or the project must be already playing) in order to make the bug occur.

This issue is actually very “simple”. At least I have pinpointed where it comes from so it’s easier for the developers to look at it.

While the sound is gone and the project still playing, the sound comes back as long as we click and hold the channel fader. As soon as we release the click the audio is gone again.
So when Read automation and Track Loop aren’t enabled simultaneously, touching the fader (just clicking the fader cap without moving the mouse is enough) or entering a value manually will fix the issue until next time you trigger it. Disabling and enabling the track again also fixes it but touching the fader is much faster.

I am sure that when we trigger this bug it makes the fader’s internal value go to -∞, like it’s telling it to get this value thousands of times per second, and holding the fader manually takes over it.
I have also tried using a Send and when we set it to Pre-fader the audio is properly audible. When set to Post-fader there is obviously no sound. In fact I have checked with the Send before looking at the fader, this is what made me think oh it’s probably the fader.
So the culprit is definitely the fader.


This is a known and already reported issue. Thank you.