individual note spacing: notes don't move

Probably I’m blind, but I do exactly what is written in the documentation. I’m in engrave mode and click on the button “Note Spacing”. Now, many squared handles appear. I expect, that I can move the handles with the mouse / trackpad. But nothing happens. They just don’t move on my computer. Can anyone help? (Dorico 2.2, MacOS 10.13.6)

You have to use Alt+arrow keys on your computer keyboard. You can’t do it with your mouse. This is an intentional decision on the part of the developers.

Thank you, that works. Not very intuitive, though.
I read this doc-page:
https://steinberg.help/dorico_pro/v2/en/dorico/topics/engrave_mode/engrave_mode_note_spacing_c.html?hl=note%2Cspacing
and didn’t realize, that there are additional doc pages about this.

It’s for the same reason that you can’t alter pitches using the mouse - in other software it’s just too easy to accidentally nudge something and not realise.

What about adding also a Shift+Alt+arrow keys to move things by 10 or 25, instead of 1 (like in some image editing programs)?
Some elements sometimes need to be moved further, like sometime I want to adjust the width of the last system, and move it 1 by 1 is very very long…

Cmd/Ctrl already does this, when you add it to Alt and the arrow keys.

Try using Ctrl/Cmd-Alt-arrow. It still takes a while for a massive move, but it’s a lot faster than just Alt-arrow.

Nice, I didn’t checked that one, since I used to use another shortcut in an image editing program that I use often. Thank you.

If your problem is whether the last system is justified or not, look at the option in Layout Options / Note Spacing. “Only justify final system when more that x% full”.

Also, adding a Note Spacing Change for the last system in Engrave mode might be a quicker way to do what you want.

Thanks Rob. I knew for the justifying option, but didn’t know the “Note Spacing Change” tool, which is really nice and useful.

Also in the Engrave mode, you also need to be in the “Graphic Editing” mode to access to the “Note Spacing Change” window. I was on the “Note spacing” mode with 1 item selected : the Note Spacing Change in the menu was enabled, but did nothing (a bug or a misuse?). In the Frames mode, this option is well disabled.

“A misuse”, not a bug.

(https://steinberg.help/dorico/v3/en/dorico/topics/engrave_mode/engrave_mode_note_spacing_change_dialog_r.html#engrave_mode_note_spacing_change_dialog_r)

Yes I saw that well. I know it’s only working with “Graphic Editing” selected :wink:

I was just pointing out a UI design issue: “Note Spacing Change” is still enabled in the Engrave menu (and do nothing if you click on it, even if you have something selected), when “Note Spacing” is selected (it’s well disabled with “Frames”). In my opinion, it should be disabled (or should work) in the menu, because here it’s bit disturbing. Especially because when you want to adjust the spacing of the notes (individually or from specific points in layouts), a first reflex could be to select the “Note Spacing” view.

It’s greyed out, here, informing the user that it’s inoperative in this mode. Are you seeing something different?

You are right, it’s greyed out if nothing is selected.

But if you select something it become enabled :

Ah, I see what you mean. How odd.