Inexplicably double-headed notes!

Hello all

I work mainly in the score editor in Cubase 8, entering notes by hand (mouse) into my orchestral template.
Was working on the oboe stave - fine, no problems - then I went to enter a minim in one of the violin stave I got a double-headed minim. Any note I enter is double headed. I cannot just delete one of the heads - if I delete it the whole note disappears. It sounds fine, but obviously looks very messy. On experimentation I find that this happens with numerous staves, but I can’t find a setting that would do this. Similarly, I can’t find any difference in settings between staves that have this problem and staves that don’t!
I’ve shut Cubase down now and I’m leaving it alone til tomorrow as I was starting to get furious!

Any idea why this might be happening?

Thanks.

No specific idea. But I’d take a look at the MIDI Part with the List Editor and see if there are any clues there.

Thanks raino
Your suggestion itself didn’t really help but further investigation has turned things up…
My template is built in a ‘separate stave for each articulation’ type way rather than keyswitches etc. When building the template I would put all my, for example, flute articulations/staves into a ‘Flutes’ folder - then I would collapse each of these instrument folders so my project view isn’t too sprawling.
Then to get to Score Editor I would hit ‘control/a’ to select everything then open Score Editor in the menu and then get my full score displayed.
If I ‘control/a’ while all the folders are collapsed and go to score editor, then any note I enter will be double headed. If I ‘control/a’ while all the folders are expanded, then any note I enter will be as it should be.

So, I’m glad I’ve found a work around - but surely this is a bug!?!?

Any thoughts?

I tried to replicate this but couldn’t. I created a bunch of midi tracks with empty midi parts on them and put them in a folder. If the folder was expanded and I selected everything with crtl+a I could open the parts in the Score Editor and enter notes normally - just like you. But if the folder was collapsed when I used ctrl+a it selected the part on the Folder Track itself, but did not select any of the midi parts inside the folder. So when I went to the Score menu the option to open the selected parts was grayed out (since no midi parts were actually selected).

I can’t get this to occur here either.
Does it happen in all your Projects, or just this one?

Hmm… Frustrating that you fine folk can’t reproduce it!

Here’s a brief (and crappy)video I just made demonstrating the issue…

https://youtu.be/3Vqbxg5rIAg

This is pretty much my first play on Cubase 8 on my new PC so no other projects to compare to yet.

Any thoughts?

How strange!
Would you have any objection to uploading the project (zipped)? If it is too big to be accepted by the forum, send me a PM, and we’ll see if you can email it to me, or possibly via DropBox or something. For the moment, I haven’t the faintest idea what could be causing this :confused: .

After watching your video I played around a bit more. I did find some further weirdness, although nothing that helps your problem.

Previously I’d just built a test with one folder and when that folder was collapsed ctrl+a did not select the parts in the folder, so it couldn’t be opened in the Score Ed. This time I made 3 folders and what I found was that if all 3 folders were collapsed then the behavior was just like my previous test - nothing got selected. But if any one of the 3 folders were open then ctrl-a selected all the parts, even the ones in the collapsed folders. :question:

I’ve seen doubled heads when I’ve accidentally duplicated the same notes twice on the same bars - but they would always show double until I deleted the doubled notes. Your’s is probably just a graphics issue since it comes and goes. What happens if you select just one of the note heads, do they both become highlighted? If not what happens if you delete just that one? Does the same thing happen if you start from scratch with a new blank project?

Maybe it is OS specific. What version of Windows are you on (forum tip, the cool kids put their DAW specs in their sig)? I’m on 7.

Thought I’d reverse follow Vic’s suggestion and post my test cpr. Does this show double heads for you?
test folders.zip (19.8 KB)

Jamie sent me the cpr, and I was able to reproduce the problem.
It seems there is a problem when using nested folder tracks (it wasn’t clear from the animated gif) but the Oboes folder track was itself enclosed in a general “Woodwinds” folder track.
After doing “Select all”, if I then de-selected all the top-level folder tracks (e.g. the “Woodwinds” folder track in this example), then the problem went away.
I was also able to re-create the problem in a new Project from scratch here… exactly the same symptoms, and similarly avoided by deselecting the top-level folder track.

@Raino
Maybe you could try placing your folder tracks inside another folder track… see if you get the same thing?

(and, yes, there is also something funky about what can be opened and what can’t… where it remained greyed out in the example you gave… try the following, for a bit of fun :wink:… go into Preferences>Event Display>MIDI, and set Default Edit Action to “Open Score Editor”. then, back in the Project window, instead of going to the MIDI menu (where it is greyed out), just double-click on a Part… and the Score Editor will open nonetheless!

Yup, with nested folders I was able to replicate the problem.

Set my default editor to Score :question: :exclamation: :question: :exclamation: :question: :exclamation: :question: :exclamation: :question: :open_mouth:
Key is my native tongue, Score is a second language for me & I have a very thick accent.

I created an issue report for this and will link to it here once it is approved.

:laughing: I didn’t ask you to do it with a welding gun! :stuck_out_tongue: (you can put it back to Key Editor after testing :wink:… and here’s a little secret… my default editor is the Key Editor too :wink: ).

Here’ the link to the issue report
http://www.steinberg.net/forums/viewtopic.php?f=230&t=89752&e=0

Thanks Raino :slight_smile:

I may be off base on this, but I may as well offer a possible solution:

I also used to have this problem, and it always happened when my MIDI Input was set to “All MIDI Inputs” - it would give me double notes everywhere! When I narrowed this to only the MIDI input device I was using, the “ghost notes” magically went away.

Sometimes the solution is very simple - it’s a shame it took me a long time to discover this one… hope it helps!

Hi,
I am guessing that, in your case, you were actually recording the notes twice (sometimes an incoming MIDI device has two “virtual” ports, and it was recording from both of them. :slight_smile: )

Vic and Raino

Thanks so much for exploring this issue so comprehensively and making such a lucid report!

There are clearly workarounds, so it’s not an intractable obstacle, but I wonder if Steinberg will actually do something about this. It’s such an odd little bug!
I’m still waiting for a solution to another odd bug I stumbled on a while back that was kindly reported by SteveIn Chicago concerning vertical scroll breaking in Score Editor if there are more than 126 staves
( http://www.steinberg.net/forums/viewtopic.php?f=231&t=86036 )
I guess finding solutions for little quirks like this are a relatively low priority.

But thanks so much for the time you took examining this particular idiosyncrasy!

As regards the “workaround” for that template, there is still a big difference between simply doing “Select All”, then opening the Score Editor, and, what would be necessary here, i.e. doing “Select All”, then individually de-selecting all the top-level folder containers, then opening the Score Editor. But (without actually reopening your project and trying it for myself :wink: ), do the above, just the one time (so that the score looks correct), then, in the Score Editor Settings dialog>Layout, give the current layout a meaningful name, then, next time you need to open the Score Editor, instead of doing Select All then going up to the MIDI>Scores menu, now there is no need to select anything… just go up to the Scores menu>Open Layout (then choose the Layout name you had written)… (in fact, I did just try a quick mock-up, and it does work here :wink: )

I’m still waiting for a solution to another odd bug I stumbled on a while back that was kindly reported by SteveIn Chicago concerning vertical scroll breaking in Score Editor if there are more than 126 staves
( > http://www.steinberg.net/forums/viewtopic.php?f=231&t=86036 > )
I guess finding solutions for little quirks like this are a relatively low priority.

But thanks so much for the time you took examining this particular idiosyncrasy!

I know that Steinberg take pride in the Score Editor, but of course “power users” (and, looking at the template you sent me, I think you qualify there :wink: ) are in the minority, so certain bugs will obviously take a while before someone comes up against one.

I suspect they won’t. This is totally speculation on my part, but since they are working on a totally new Scoring application it doesn’t make sense to address any but the most significant problems. Because eventually the current score capabilities will probably get replaced. Again this is only speculation.

Vic’s advice on Layouts is spot on (as usual). Layouts make things much easier.