Infinite hanging MIDI notes

In select MIDI events, the last note(s) will play forever if I don’t automate their volume down to zero. I have seen that this is an issue in Cubase versions going back to 6 at least, and still haven’t figured out how to fix it. I thought it was the MIDI Thru Active setting, but turning that off didn’t solve it.

Hi,

I don’t have this issue on my side.

Could you try to rename/remove all your Cubase preferences folders and then start Cubase, please? This will start Cubase in the Factory Settings.

Cubase Preferences folders are:
Mac: ~/Library/Preferences/Cubase X
Win: %appData% \Steinberg\Cubase X_64

Where the X is the Cubase version (for example 13).